summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndi Shyti <andi@etezian.org>2016-06-26 16:23:56 +0300
committerAndi Shyti <andi@smida.it>2017-02-19 05:17:14 +0200
commit7466788e4008eaa6cd9ed651b7871986452ef2ce (patch)
tree7ef8e85fde37cdbe5dd351c70dd2d7a6a7c8801a
parentc273e4907a3bcdb86e1a61cc6b9d584358ed7b2a (diff)
package: add Odroid BL bootloader binaries
The odroid boot process requires three stages of boot plus trust zone: boot level 1 | V boot level 2 | V u-boot and they need to be raw copied to the SD card in the following order: +----------------+----------------+ | boot level 1 | 1 block | +----------------+----------------+ | boot level 2 | 31 block | +----------------+----------------+ | u-boot | 63 block | +----------------+----------------+ | trust zone | 2111 block | +----------------+----------------+ | boot partition | 4096 block | +----------------+----------------+ | rootfs | | +----------------+----------------+ The above files are provided by the hardkernel u-boot from https://github.com/hardkernel/u-boot/tree/odroidxu3-v2012.07 At the end of the compilation the files will be moved to the output/image directory. Signed-off-by: Andi Shyti <andi@etezian.org>
-rw-r--r--package/Config.in1
-rw-r--r--package/odroid-xu-bl/Config.in6
-rw-r--r--package/odroid-xu-bl/odroid-xu-bl.mk18
3 files changed, 25 insertions, 0 deletions
diff --git a/package/Config.in b/package/Config.in
index deff0fe2c..e711fc940 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -337,6 +337,7 @@ menu "Firmware"
source "package/am33x-cm3/Config.in"
source "package/b43-firmware/Config.in"
source "package/linux-firmware/Config.in"
+ source "package/odroid-xu-bl/Config.in"
source "package/rpi-firmware/Config.in"
source "package/sunxi-boards/Config.in"
source "package/ts4900-fpga/Config.in"
diff --git a/package/odroid-xu-bl/Config.in b/package/odroid-xu-bl/Config.in
new file mode 100644
index 000000000..74d5fe2be
--- /dev/null
+++ b/package/odroid-xu-bl/Config.in
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_ODROID_XU_BL
+ bool "odroid-xu-bl"
+ help
+ Odroid XU3/4 bootloader binaries
+
+ https://github.com/hardkernel/u-boot/tree/odroidxu3-v2012.07
diff --git a/package/odroid-xu-bl/odroid-xu-bl.mk b/package/odroid-xu-bl/odroid-xu-bl.mk
new file mode 100644
index 000000000..68645e92a
--- /dev/null
+++ b/package/odroid-xu-bl/odroid-xu-bl.mk
@@ -0,0 +1,18 @@
+################################################################################
+#
+# odroid-xu-bl
+#
+################################################################################
+
+ODROID_XU_BL_VERSION = odroidxu3-v2012.07
+ODROID_XU_BL_SITE = $(call github,hardkernel,u-boot,$(ODROID_XU_BL_VERSION))
+ODROID_XU_BL_INSTALL_IMAGES = YES
+ODROID_XU_BL_INSTALL_TARGET = NO
+
+define ODROID_XU_BL_INSTALL_IMAGES_CMDS
+ $(INSTALL) -D -m 0644 $(@D)/sd_fuse/hardkernel_1mb_uboot/bl1.bin.hardkernel $(BINARIES_DIR)/bl1.bin.hardkernel
+ $(INSTALL) -D -m 0644 $(@D)/sd_fuse/hardkernel_1mb_uboot/bl2.bin.hardkernel.1mb_uboot $(BINARIES_DIR)/bl2.bin.hardkernel.1mb_uboot
+ $(INSTALL) -D -m 0644 $(@D)/sd_fuse/hardkernel_1mb_uboot/tzsw.bin.hardkernel $(BINARIES_DIR)/tzsw.bin.hardkernel
+endef
+
+$(eval $(generic-package))