summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYegor Yefremov <yegorslists@googlemail.com>2017-02-06 16:56:24 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2017-02-06 17:17:35 +0100
commitc9129558b960de1264319e8518d74674a877d5b5 (patch)
tree12517f4ec9ff9a2d999e69c57cd166365a820cf2
parent9ebf0a963f86889bb6d71feb79b1ef83fa7232be (diff)
python-bitstring: new package
Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-rw-r--r--package/Config.in1
-rw-r--r--package/python-bitstring/Config.in6
-rw-r--r--package/python-bitstring/python-bitstring.hash2
-rw-r--r--package/python-bitstring/python-bitstring.mk14
4 files changed, 23 insertions, 0 deletions
diff --git a/package/Config.in b/package/Config.in
index 907b1e674..114a5ad5f 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -655,6 +655,7 @@ menu "External python modules"
source "package/python-babel/Config.in"
source "package/python-backports-abc/Config.in"
source "package/python-beautifulsoup4/Config.in"
+ source "package/python-bitstring/Config.in"
source "package/python-bottle/Config.in"
source "package/python-can/Config.in"
source "package/python-cbor/Config.in"
diff --git a/package/python-bitstring/Config.in b/package/python-bitstring/Config.in
new file mode 100644
index 000000000..93d768257
--- /dev/null
+++ b/package/python-bitstring/Config.in
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_PYTHON_BITSTRING
+ bool "python-bitstring"
+ help
+ Simple construction, analysis and modification of binary data.
+
+ https://github.com/scott-griffiths/bitstring
diff --git a/package/python-bitstring/python-bitstring.hash b/package/python-bitstring/python-bitstring.hash
new file mode 100644
index 000000000..52630e0aa
--- /dev/null
+++ b/package/python-bitstring/python-bitstring.hash
@@ -0,0 +1,2 @@
+# Locally computed:
+sha256 b769620c1b52d6c1548c6c4f055613f4eee3120ed8a5cff4ba4ffbbc8a582286 bitstring-3.1.5.tar.gz
diff --git a/package/python-bitstring/python-bitstring.mk b/package/python-bitstring/python-bitstring.mk
new file mode 100644
index 000000000..2c8fb9959
--- /dev/null
+++ b/package/python-bitstring/python-bitstring.mk
@@ -0,0 +1,14 @@
+################################################################################
+#
+# python-bitstring
+#
+################################################################################
+
+PYTHON_BITSTRING_VERSION = 3.1.5
+PYTHON_BITSTRING_SOURCE = bitstring-$(PYTHON_BITSTRING_VERSION).tar.gz
+PYTHON_BITSTRING_SITE = https://github.com/scott-griffiths/bitstring/archive
+PYTHON_BITSTRING_SETUP_TYPE = distutils
+PYTHON_BITSTRING_LICENSE = MIT
+PYTHON_BITSTRING_LICENSE_FILES = LICENSE
+
+$(eval $(python-package))