summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Korsgaard <peter@korsgaard.com>2017-02-18 14:18:05 +0100
committerPeter Korsgaard <peter@korsgaard.com>2017-02-18 15:48:12 +0100
commit95e7d45f2853238d06a71a9ac94505689e4c1809 (patch)
tree9de9692a3a8f2ed6451ef360fbf02a8d599ad49e
parent87c89c041aa60e6ab652ec8256905718057fc53c (diff)
gstreamer1: drop unused configure time unaligned access handling logic
gstreamer has moved to build time unaligned access support detection using ifdefs in gstconfig.h since 1.9.2: commit 6ef601367e0f5adb7a8b02cec94dec04fccf701a Author: Nirbheek Chauhan <nirbheek@centricular.com> Date: Tue Jun 21 18:59:49 2016 +0530 gstconfig.h: Detect unaligned access support at compile-time This makes gstconfig.h completely arch-independent. Should cover all compilers that gstreamer is known to build on, and all architectures that I could find information on. People are encouraged to file bugs if their platform/arch is missing. So ac_cv_unaligned_access is no longer used and our logic can be removed. Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
-rw-r--r--package/gstreamer1/gstreamer1/gstreamer1.mk10
1 files changed, 0 insertions, 10 deletions
diff --git a/package/gstreamer1/gstreamer1/gstreamer1.mk b/package/gstreamer1/gstreamer1/gstreamer1.mk
index ac2c98870..e110dee7d 100644
--- a/package/gstreamer1/gstreamer1/gstreamer1.mk
+++ b/package/gstreamer1/gstreamer1/gstreamer1.mk
@@ -11,16 +11,6 @@ GSTREAMER1_INSTALL_STAGING = YES
GSTREAMER1_LICENSE_FILES = COPYING
GSTREAMER1_LICENSE = LGPLv2+, LGPLv2.1+
-# Checking if unaligned memory access works correctly cannot be done when cross
-# compiling. For the following architectures there is no information available
-# in the configure script.
-ifeq ($(BR2_arc)$(BR2_xtensa)$(BR2_microblaze)$(BR2_nios2),y)
-GSTREAMER1_CONF_ENV = as_cv_unaligned_access=no
-endif
-ifeq ($(BR2_aarch64),y)
-GSTREAMER1_CONF_ENV = as_cv_unaligned_access=yes
-endif
-
GSTREAMER1_CONF_OPTS = \
--disable-examples \
--disable-tests \