summaryrefslogtreecommitdiff
path: root/linux
diff options
context:
space:
mode:
authorPeter Korsgaard <peter@korsgaard.com>2016-09-02 16:20:33 +0200
committerPeter Korsgaard <peter@korsgaard.com>2016-09-02 16:20:33 +0200
commit7353967690b425fd6519756979f3ef839b1a9cd1 (patch)
treea910fd6b794556251fe607295c631aed98534235 /linux
parentcff53ce35b8dab3bbdd9aa4471d1ecb3238c9fab (diff)
parent1bd02bc230e1b3b22ca3eb23fb3dcb91b878283a (diff)
Merge branch 'next'
Quite some conflicts, so here goes .. Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'linux')
-rw-r--r--linux/Config.in13
-rw-r--r--linux/linux.mk3
2 files changed, 0 insertions, 16 deletions
diff --git a/linux/Config.in b/linux/Config.in
index c7bc4d845..43d63c0cd 100644
--- a/linux/Config.in
+++ b/linux/Config.in
@@ -68,12 +68,6 @@ config BR2_LINUX_KERNEL_CUSTOM_SVN
This option allows Buildroot to get the Linux kernel source
code from a Subversion repository.
-config BR2_LINUX_KERNEL_CUSTOM_LOCAL
- bool "Local directory"
- help
- This option allows Buildroot to get the Linux kernel source
- code from a local directory.
-
endchoice
config BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE
@@ -101,12 +95,6 @@ config BR2_LINUX_KERNEL_CUSTOM_REPO_VERSION
endif
-config BR2_LINUX_KERNEL_CUSTOM_LOCAL_PATH
- string "Path to the local directory"
- depends on BR2_LINUX_KERNEL_CUSTOM_LOCAL
- help
- Path to the local directory with the Linux kernel source code.
-
config BR2_LINUX_KERNEL_VERSION
string
default "4.7.2" if BR2_LINUX_KERNEL_LATEST_VERSION
@@ -115,7 +103,6 @@ config BR2_LINUX_KERNEL_VERSION
default "custom" if BR2_LINUX_KERNEL_CUSTOM_TARBALL
default BR2_LINUX_KERNEL_CUSTOM_REPO_VERSION \
if BR2_LINUX_KERNEL_CUSTOM_GIT || BR2_LINUX_KERNEL_CUSTOM_HG || BR2_LINUX_KERNEL_CUSTOM_SVN
- default "custom" if BR2_LINUX_KERNEL_CUSTOM_LOCAL
#
# Patch selection
diff --git a/linux/linux.mk b/linux/linux.mk
index fb844ef7a..6e41a920a 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -21,9 +21,6 @@ LINUX_TARBALL = $(call qstrip,$(BR2_LINUX_KERNEL_CUSTOM_TARBALL_LOCATION))
LINUX_SITE = $(patsubst %/,%,$(dir $(LINUX_TARBALL)))
LINUX_SOURCE = $(notdir $(LINUX_TARBALL))
BR_NO_CHECK_HASH_FOR += $(LINUX_SOURCE)
-else ifeq ($(BR2_LINUX_KERNEL_CUSTOM_LOCAL),y)
-LINUX_SITE = $(call qstrip,$(BR2_LINUX_KERNEL_CUSTOM_LOCAL_PATH))
-LINUX_SITE_METHOD = local
else ifeq ($(BR2_LINUX_KERNEL_CUSTOM_GIT),y)
LINUX_SITE = $(call qstrip,$(BR2_LINUX_KERNEL_CUSTOM_REPO_URL))
LINUX_SITE_METHOD = git