summaryrefslogtreecommitdiff
path: root/package/ddrescue/ddrescue.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/ddrescue/ddrescue.mk')
-rw-r--r--package/ddrescue/ddrescue.mk19
1 files changed, 19 insertions, 0 deletions
diff --git a/package/ddrescue/ddrescue.mk b/package/ddrescue/ddrescue.mk
new file mode 100644
index 000000000..23f03436e
--- /dev/null
+++ b/package/ddrescue/ddrescue.mk
@@ -0,0 +1,19 @@
+################################################################################
+#
+# ddrescue
+#
+################################################################################
+
+DDRESCUE_VERSION = 1.22
+DDRESCUE_SOURCE = ddrescue-$(DDRESCUE_VERSION).tar.lz
+DDRESCUE_SITE = http://download.savannah.gnu.org/releases/ddrescue
+DDRESCUE_LICENSE = GPLv2+
+DDRESCUE_LICENSE_FILES = COPYING
+DDRESCUE_DEPENDENCIES = host-lzip
+
+define DDRESCUE_EXTRACT_CMDS
+ $(HOST_DIR)/usr/bin/lzip -d -c $(DL_DIR)/$(DDRESCUE_SOURCE) | \
+ tar --strip-components=1 -C $(@D) $(TAR_OPTIONS) -
+endef
+
+$(eval $(autotools-package))