summaryrefslogtreecommitdiff
path: root/benchmarks/meson.build
diff options
context:
space:
mode:
authorTvrtko Ursulin <tvrtko.ursulin@intel.com>2020-06-17 16:04:17 +0100
committerTvrtko Ursulin <tvrtko.ursulin@intel.com>2020-06-19 16:37:11 +0100
commiteba9936b06e1dab092a965a20df12ea61c00ef66 (patch)
treee10e1777e4050a4840f903af678c3f95fb89aa89 /benchmarks/meson.build
parenteba1135ddd35f9d3097ed91032aefe8f9a9f9d02 (diff)
gem_wsim: Rip out userspace balancing
Evaluation of userspace load balancing options was how this tool started but since we have settled on doing it in the kernel. Tomorrow we will want to update the tool for new engine interfaces and all this legacy code will just be a distraction. Rip out everything not related to explicit load balancing implemented via context engine maps and adjust the workloads to use it. Signed-off-by: Tvrtko Ursulin <tvrtko.ursulin@intel.com> Acked-by: Chris Wilson <chris@chris-wilson.co.uk>
Diffstat (limited to 'benchmarks/meson.build')
-rw-r--r--benchmarks/meson.build6
1 files changed, 1 insertions, 5 deletions
diff --git a/benchmarks/meson.build b/benchmarks/meson.build
index ef93193b..c70e1aac 100644
--- a/benchmarks/meson.build
+++ b/benchmarks/meson.build
@@ -11,6 +11,7 @@ benchmark_progs = [
'gem_prw',
'gem_set_domain',
'gem_syslatency',
+ 'gem_wsim',
'kms_vblank',
'prime_lookup',
'vgem_mmap',
@@ -34,8 +35,3 @@ foreach prog : benchmark_progs
install_dir : benchmarksdir,
dependencies : igt_deps)
endforeach
-
-executable('gem_wsim', 'gem_wsim.c',
- install : true,
- install_dir : benchmarksdir,
- dependencies : igt_deps + [ lib_igt_perf ])