summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorArkadiusz Hiler <arkadiusz.hiler@intel.com>2019-09-09 16:46:45 +0300
committerPetri Latvala <petri.latvala@intel.com>2019-09-17 13:08:47 +0300
commit933b84d5585698e15542ea1c5627d5d8d63ce230 (patch)
tree5fdd7ee96b55704131885df7b635fddbaed68266 /meson.build
parentee70b403149456a940d540e8d0ec739d9725f273 (diff)
meson: Bump required version to 0.47.2
Any distribution that decided to go with 0.47 should also pack the latest point release. For us 0.47.2 is important because it fixes the weird issues with using a 'feature' option as a dependency()'s 'required' parameter, e.g.: option('oping', type : 'feature', description : 'Build test runner with liboping for pinging support') liboping = dependency('liboping', required: get_option('oping')) With liboping not installed and oping option having the default "auto" value this should execute just fine and liboping.found() should == false, but instead we get "ERROR: Native dependency 'liboping' not found". That behavior is fixed with 0.47.2. Cc: Petri Latvala <petri.latvala@intel.com> Signed-off-by: Arkadiusz Hiler <arkadiusz.hiler@intel.com> Reviewed-by: Petri Latvala <petri.latvala@intel.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index aeecf0dc..fd3b6324 100644
--- a/meson.build
+++ b/meson.build
@@ -7,7 +7,7 @@ project('igt-gpu-tools', 'c',
'buildtype=debugoptimized',
],
license : 'MIT',
- meson_version : '>=0.47.0')
+ meson_version : '>=0.47.2')
if get_option('b_ndebug') != 'false'
error('Building without -Db_ndebug=false is not supported')