summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorLionel Landwerlin <lionel.g.landwerlin@intel.com>2021-04-22 21:40:54 +0300
committerLionel Landwerlin <lionel.g.landwerlin@intel.com>2021-05-21 13:47:53 +0300
commitb4a876b3a1a871f43070c8756e440004c97f829a (patch)
treed177ae2eea933f3a6263cffdad81cb598bc0a5f7 /meson.build
parentd53068fe9146bd89aed837b344c79e4367bdb4c1 (diff)
lib/i915/perf: have python scripts a custom_target input
That way when changing the scripts, the generated files are regenerated. This change makes python3 an explicit hard dependency, but that was already the case for lib/i915/perf. Signed-off-by: Lionel Landwerlin <lionel.g.landwerlin@intel.com> Reviewed-by: Umesh Nerlige Ramappa <umesh.nerlige.ramappa@intel.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 5d9655f7..06e76189 100644
--- a/meson.build
+++ b/meson.build
@@ -262,6 +262,7 @@ libexecdir = join_paths(get_option('libexecdir'), 'igt-gpu-tools')
amdgpudir = join_paths(libexecdir, 'amdgpu')
mandir = get_option('mandir')
pkgconfigdir = join_paths(libdir, 'pkgconfig')
+python3 = find_program('python3', required : true)
if get_option('use_rpath')
# Set up runpath for the test executables towards libigt.so.
@@ -316,8 +317,7 @@ subdir('overlay')
subdir('man')
gtk_doc = dependency('gtk-doc', required : build_docs)
-python3 = find_program('python3', required : build_docs)
-if build_tests and gtk_doc.found() and python3.found()
+if build_tests and gtk_doc.found()
subdir('docs')
elif build_docs.enabled()
error('Documentation requires building tests')