summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPetri Latvala <petri.latvala@intel.com>2021-02-01 08:33:39 +0200
committerPetri Latvala <petri.latvala@intel.com>2021-02-01 10:44:38 +0200
commitcfb04c4a6171575f8782fe1dd5c63700ad33799e (patch)
treefae666265aaa8502ea1917b5eb49d10d9ea35517 /meson.build
parent743c8e5cd78b583e6b98dbc22c5cef9aa7130d6a (diff)
meson: Turn off -Werror
No, we don't want all warnings ever to be errors. While being rid of compile warnings (especially the more obscure ones from future compilers) is great, having it on always is not acceptable. It's not even on "by default", it was non-overrideably set on. Not to mention adding -Werror to compiler flags is the incorrect way of turning it on. Use the meson command line flag --werror instead on whatever local checkout or company-internal fork you're using, where you have control over which compilers are used. Turning it on unconditionally in an upstream repository for all current and future compilers is never ok. This partially reverts commit e02612921a4e95aef3a368e7468f4337c9dcee7d. Signed-off-by: Petri Latvala <petri.latvala@intel.com> Cc: Ashutosh Dixit <ashutosh.dixit@intel.com> Cc: Chris Wilson <chris@chris-wilson.co.uk> Cc: Arkadiusz Hiler <arek@hiler.eu> Reviewed-by: Chris Wilson <chris@chris-wilson.co.uk>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build28
1 files changed, 13 insertions, 15 deletions
diff --git a/meson.build b/meson.build
index 3f3693f9..f4ee14f1 100644
--- a/meson.build
+++ b/meson.build
@@ -51,21 +51,19 @@ cc_args = [
'-Wno-unused-parameter',
'-Wno-unused-result',
- '-Waddress',
- '-Warray-bounds',
- '-Wimplicit',
- '-Winit-self',
- '-Wint-to-pointer-cast',
- '-Wmain',
- '-Wmissing-braces',
- '-Wnonnull',
- '-Wpointer-to-int-cast',
- '-Wreturn-type',
- '-Wsequence-point',
- '-Wtrigraphs',
- '-Wwrite-strings',
-
- '-Werror',
+ '-Werror=address',
+ '-Werror=array-bounds',
+ '-Werror=implicit',
+ '-Werror=init-self',
+ '-Werror=int-to-pointer-cast',
+ '-Werror=main',
+ '-Werror=missing-braces',
+ '-Werror=nonnull',
+ '-Werror=pointer-to-int-cast',
+ '-Werror=return-type',
+ '-Werror=sequence-point',
+ '-Werror=trigraphs',
+ '-Werror=write-strings',
# Disable the memory allocating builtins as they may cause unexpected behavior
# with our framework. They *may* get optimized out in favor of a register or
# stack variable, making them effectively local. Local variables do not play