summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPetri Latvala <petri.latvala@intel.com>2019-10-07 14:55:51 +0300
committerPetri Latvala <petri.latvala@intel.com>2019-10-09 14:51:34 +0300
commite501741f2e2b086a8c55d9f278c630ce68ad5fe1 (patch)
treebe9740b38420001514e2cf4449bab3f403603a1e /meson.build
parent869ed1ee0b71ce17f0a864512488f8b1a6cb8545 (diff)
meson: Remove redundant install params from configure_file
The 'install' param for configure_file was added in meson 0.50, and does nothing before that. When using meson >= 0.50 using the install param gives a warning if the minimum required meson version is lower than 0.50, because of reasons. 'install : false' is the default anyway when install_dir param is not set, so remove the redundant and erroneous install param usages. Signed-off-by: Petri Latvala <petri.latvala@intel.com> Cc: Joonas Lahtinen <joonas.lahtinen@linux.intel.com> Cc: Arkadiusz Hiler <arkadiusz.hiler@intel.com> Reviewed-by: Arkadiusz Hiler <arkadiusz.hiler@intel.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index fd3b6324..4d5003ba 100644
--- a/meson.build
+++ b/meson.build
@@ -239,7 +239,7 @@ config.set_quoted('PACKAGE', meson.project_name())
config.set('PACKAGE_STRING', meson.project_name() + ' ' + meson.project_version())
config.set_quoted('TARGET_CPU_PLATFORM', host_machine.cpu_family())
-configure_file(output: 'config.h', install: false, configuration: config)
+configure_file(output: 'config.h', configuration: config)
prefix = get_option('prefix')
bindir = get_option('bindir')