summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPetri Latvala <petri.latvala@intel.com>2019-05-20 12:39:24 +0300
committerPetri Latvala <petri.latvala@intel.com>2019-05-20 13:37:19 +0300
commiteff5d0db3248734845b78fcc2e2772dd4012e5af (patch)
treece5a67a28617ddaf7e522c5ba34417a8ea61e692 /meson.build
parent6fe5d254ec1b9b47d61408e1b49a7339876bf1e7 (diff)
meson: Remove invalid required argument
declare_dependency doesn't take a 'required' argument. meson.build:207: WARNING: Passed invalid keyword argument "required". WARNING: This will become a hard error in the future. Signed-off-by: Petri Latvala <petri.latvala@intel.com> Cc: Simon Ser <simon.ser@intel.com> Reviewed-by: Simon Ser <simon.ser@intel.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index a05e912c..2af08f9a 100644
--- a/meson.build
+++ b/meson.build
@@ -210,7 +210,7 @@ if _build_chamelium
xmlrpc_client,
gsl,
alsa,
- ], required : _chamelium_required)
+ ])
if xmlrpc.found() and xmlrpc_util.found() and xmlrpc_client.found() and gsl.found() and alsa.found() and libcurl.found()
config.set('HAVE_CHAMELIUM', 1)
chameliuminfo = 'Yes'