summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDaniel Vetter <daniel.vetter@ffwll.ch>2017-12-05 11:16:49 +0100
committerDaniel Vetter <daniel.vetter@ffwll.ch>2017-12-05 16:19:53 +0100
commit491e8c173e288931101e21f5f6f48f098f16d876 (patch)
treee6ca29c20c7d4ca3608657028fae4afa31a7eb58 /meson.build
parent10e3e5d4ef04e4b6318aa05795dd5aba60ded689 (diff)
meson: gtkdoc support
Bunch of neat improvements: - xml generates correctly depend upon the test binaries - no need to re-run autogen.sh when new chapters/functions get added, all handed by meson Still one issue: - the gtkdoc target doesn't depend upon the custom_target yet, hacked around using build_by_default: true This is an issue known to upstream already: https://github.com/mesonbuild/meson/issues/2148 v2: Bump meson version to 0.42, since that's the first release which adds the build dir when running the gtkdoc tools, and hence allows including generated files. v2: - Undo the bump, it's only needed for generated source files. Other generated files as input should work with 0.40 already. - Generate version.xml from version.xml.in, which allows us to keep the &version; entity. v3: Add github issue link. v4: - Resurrect lost KEYWORDS (Petri) - Fix issue when running with a clean build, files() doesn't work on generate files (Petri). Reviewed-by: Petri Latvala <petri.latvala@intel.com> Signed-off-by: Daniel Vetter <daniel.vetter@ffwll.ch>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index a564893d..0950d3c7 100644
--- a/meson.build
+++ b/meson.build
@@ -28,6 +28,8 @@ endforeach
inc = include_directories('include/drm-uapi', 'lib', '.')
+inc_for_gtkdoc = include_directories('lib')
+
config = configuration_data()
libdrm = dependency('libdrm', version : '>=2.4.82')
@@ -136,3 +138,4 @@ if libdrm_intel.found()
endif
endif
subdir('man')
+subdir('docs')