summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPetri Latvala <petri.latvala@intel.com>2018-02-23 13:10:58 +0200
committerPetri Latvala <petri.latvala@intel.com>2018-02-26 11:53:05 +0200
commita2664f86bb75e642c432531e2bf30e030fb3e828 (patch)
treedf5909ff8153226de464737040ad63ab73ba529b /meson.build
parentd7e0cc6ca4174871660ec78a5a063d9b564e120c (diff)
meson: Don't build docs when cross-compiling
Building documentation requires executing all test binaries to produce their respective description texts. This can be a very time-consuming process, if viable at all, when the target arch differs from the host. Don't process the doc directory at all when an exe wrapper is setup. This avoids the runtime penalty when the target binaries are executed through qemu, but leaves everything as-is when the target binaries can be directly executed, like when cross-compiling to x86 from x86_64 host. Signed-off-by: Petri Latvala <petri.latvala@intel.com> Cc: Eric Anholt <eric@anholt.net> Reviewed-by: Eric Anholt <eric@anholt.net>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 4 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 509ae5de..0d496718 100644
--- a/meson.build
+++ b/meson.build
@@ -147,4 +147,7 @@ if libdrm_intel.found()
endif
endif
subdir('man')
-subdir('docs')
+# has_exe_wrapper() is undefined if building natively
+if not meson.is_cross_build() or not meson.has_exe_wrapper()
+ subdir('docs')
+endif