summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEric Anholt <eric@anholt.net>2017-09-27 11:30:52 -0700
committerEric Anholt <eric@anholt.net>2017-10-03 11:56:57 -0700
commitb26e9185645a4344e113a98428cd3c342d09d024 (patch)
tree5ee5ac65b4be617aa78ad1fbd1da607573188b13 /meson.build
parent2a74ae550842cfe216bff28725e1a24db3b56792 (diff)
meson: Disable the intel overlay on non-x86 builds.
It's got calls to rmb/wmb that end up not linking successfully. Signed-off-by: Eric Anholt <eric@anholt.net> Reviewed-by: Petri Latvala <petri.latvala@intel.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 1cc501f3..7a092282 100644
--- a/meson.build
+++ b/meson.build
@@ -121,6 +121,8 @@ subdir('benchmarks')
subdir('tools')
if libdrm_intel.found()
subdir('assembler')
- subdir('overlay')
+ if ['x86', 'x86_64'].contains(host_machine.cpu_family())
+ subdir('overlay')
+ endif
endif
subdir('man')