summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMaxime Ripard <maxime.ripard@bootlin.com>2018-10-04 14:39:01 +0200
committerArkadiusz Hiler <arkadiusz.hiler@intel.com>2018-10-08 16:54:06 +0300
commitddb382855e25cd0fd81c56f75f380d4c4422fbad (patch)
treeebd4479f475f236820ce1ccc3717373680634767 /meson.build
parente3b1c3498abf54377245e6d298b4cbcef663d8b4 (diff)
igt: Make pixman mandatory
So far, pixman was used exclusively when the Chamelium support was enabled. However, since we're going to use it as one of the backend to do the igt_fb conversions between formats, we'll need it all the time. Make that explicit. Signed-off-by: Maxime Ripard <maxime.ripard@bootlin.com> Reviewed-by: Arkadiusz Hiler <arkadiusz.hiler@intel.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 3 insertions, 6 deletions
diff --git a/meson.build b/meson.build
index faf1b764..eff35585 100644
--- a/meson.build
+++ b/meson.build
@@ -105,6 +105,7 @@ libprocps = dependency('libprocps', required : true)
libunwind = dependency('libunwind', required : true)
libdw = dependency('libdw', required : true)
ssl = dependency('openssl', required : true)
+pixman = dependency('pixman-1', required : true)
valgrind = null_dep
valgrindinfo = 'No'
@@ -123,16 +124,12 @@ glib = dependency('glib-2.0', required : true)
gsl = null_dep
alsa = null_dep
-pixman = null_dep
if _build_audio or _build_chamelium
gsl = dependency('gsl', required : _audio_required or _chamelium_required)
endif
if _build_audio
alsa = dependency('alsa', required : _audio_required)
endif
-if _build_chamelium
- pixman = dependency('pixman-1', required : _chamelium_required)
-endif
audioinfo = 'No'
if _build_audio and alsa.found() and gsl.found()
@@ -164,8 +161,8 @@ endif
chamelium = null_dep
chameliuminfo = 'No'
-if _build_chamelium and pixman.found() and gsl.found() and xmlrpc.found() and xmlrpc_util.found() and xmlrpc_client.found()
- chamelium = declare_dependency(dependencies : [ pixman, xmlrpc,
+if _build_chamelium and gsl.found() and xmlrpc.found() and xmlrpc_util.found() and xmlrpc_client.found()
+ chamelium = declare_dependency(dependencies : [ xmlrpc,
xmlrpc_util, xmlrpc_client])
config.set('HAVE_CHAMELIUM', 1)
chameliuminfo = 'Yes'