summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
authorNiranjana Vishwanathapura <niranjana.vishwanathapura@intel.com>2022-07-01 16:05:45 -0700
committerAndi Shyti <andi.shyti@linux.intel.com>2022-07-09 02:43:54 +0200
commit5a0acfd16097ebeeacfcbdc28d942e22da0d2abc (patch)
treef3a09d8300f1dbfe73085bc6064855d8fd2bbd20 /tests/meson.build
parentd33d1f0df600f6b8a868daa23832749e26b09b55 (diff)
tests/i915/vm_bind: Add basic VM_BIND test support
Add basic tests for VM_BIND functionality. Bind the buffer objects in device page table with VM_BIND calls and have GPU copy the data from a source buffer object to destination buffer object. Test for different buffer sizes, buffer object placement and with multiple contexts. Signed-off-by: Niranjana Vishwanathapura <niranjana.vishwanathapura@intel.com>
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/meson.build b/tests/meson.build
index 56abc7e0..8543cce9 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -250,6 +250,7 @@ i915_progs = [
'sysfs_preempt_timeout',
'sysfs_timeslice_duration',
'i915_vm_bind_sanity',
+ 'i915_vm_bind_basic',
]
msm_progs = [