summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
authorJessica Zhang <quic_jesszhan@quicinc.com>2022-04-21 10:28:58 -0700
committerAbhinav Kumar <quic_abhinavk@quicinc.com>2022-04-25 11:50:49 -0700
commitc133e54369ea4d4fcb56df659f07c74952e69ab8 (patch)
treeafff1eec0fb53edeec147cb386de3c451662ed73 /tests/meson.build
parentcbe10bd742faf5e4f6fdec9be8a75365d1319a88 (diff)
meson: Move MSM-specific tests to their own subdirectory
Move all custom MSM tests to their own subdirectory and have them installed in an msm/ subdirectory Changes from v1: - Removed extra whitespace - Moved meson build commands for msm tests from tests/msm/meson.build to tests/meson.build Changes from v2: - Removed unused variables Acked-by: Petri Latvala <petri.latvala@intel.com> Signed-off-by: Jessica Zhang <quic_jesszhan@quicinc.com>
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build18
1 files changed, 15 insertions, 3 deletions
diff --git a/tests/meson.build b/tests/meson.build
index 7261e9aa..fb0f1e37 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -63,9 +63,6 @@ test_progs = [
'kms_vrr',
'kms_writeback',
'meta_test',
- 'msm_mapping',
- 'msm_recovery',
- 'msm_submit',
'panfrost_get_param',
'panfrost_gem_new',
'panfrost_prime',
@@ -253,6 +250,12 @@ i915_progs = [
'sysfs_timeslice_duration',
]
+msm_progs = [
+ 'msm_mapping',
+ 'msm_recovery',
+ 'msm_submit'
+]
+
test_deps = [ igt_deps ]
if libdrm_nouveau.found()
@@ -294,6 +297,15 @@ foreach prog : i915_progs
test_list += prog
endforeach
+foreach prog : msm_progs
+ test_executables += executable(prog, join_paths('msm', prog + '.c'),
+ dependencies : test_deps,
+ install_dir : libexecdir,
+ install_rpath : libexecdir_rpathdir,
+ install : true)
+ test_list += prog
+endforeach
+
test_executables += executable('drm_fdinfo',
join_paths('i915', 'drm_fdinfo.c'),
dependencies : test_deps + [ lib_igt_drm_fdinfo ],