summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
authorBhanuprakash Modem <bhanuprakash.modem@intel.com>2021-07-09 21:29:45 +0530
committerSwati Sharma <swati2.sharma@intel.com>2021-07-09 17:21:03 +0530
commitcd63c83e23789eb194d38b8d272247a88122f2f6 (patch)
treeb2ddcd4499c04b618f4cdcd8e17540716d3020b1 /tests/meson.build
parentb5c6b973e7f7d33e7521825e39ddd380e80af01a (diff)
tests/kms_dither: New IGT to validate crtc Dithering
Many of the display devices have color format support less than the color format of the input data (Ex: 8-bit input data and 6-bit display color depth). Then the input data will be either truncated or rounded, but this approach usually causes loss of detail and also produce large banded areas of a single color that significantly differs from the original image. Dithering is a technique used to enhance these colors by creating the illusion of smoothness by adjusting the nearby pixel color. For Eg: Converting 8-bit to 6-bit by modifying the pixel information. Dithering should be enabled when a panel color depth is lower than the color depth of the framebuffer. Even though feature Dithering is there since legacy, there is no specific IGT for this. This patch will create New IGT for Dithering. And below is the truth table for CRTC Dithering. |----------------|---------|-------------| | Frame buffer | Panel | Dithering | |----------------|---------|-------------| | 8 BPC | 6 BPC | Yes | |----------------|---------|-------------| | 8 BPC | 8 BPC | No | |----------------|---------|-------------| | 8 BPC | 10 BPC | No | |----------------|---------|-------------| | 10 BPC | 6 BPC | Yes | |----------------|---------|-------------| | 10 BPC | 8 BPC | Yes | |----------------|---------|-------------| | 10 BPC | 10 BPC | No | |----------------|---------|-------------| | 16 BPC | 6 BPC | Yes | |----------------|---------|-------------| | 16 BPC | 8 BPC | Yes | |----------------|---------|-------------| | 16 BPC | 10 BPC | Yes | |----------------|---------|-------------| As i915 enables dithering for 6 bpc panels only, we need to limit the execution to 6 & 8 bpc panels (Negative testing) only. V2: * Connector MAX_BPC prop is mandatory (Uma) * Test commit for connector caps (Uma) Cc: Swati Sharma <swati2.sharma@intel.com> Cc: Uma Shankar <uma.shankar@intel.com> Cc: Nischal Varide <nischal.varide@intel.com> Signed-off-by: Bhanuprakash Modem <bhanuprakash.modem@intel.com> Reviewed-by: Uma Shankar <uma.shankar@intel.com>
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/meson.build b/tests/meson.build
index 01911c45..d3de40be 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -29,6 +29,7 @@ test_progs = [
'kms_cursor_crc',
'kms_cursor_edge_walk',
'kms_cursor_legacy',
+ 'kms_dither',
'kms_dp_aux_dev',
'kms_dp_dsc',
'kms_dp_tiled_display',