summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4208f000..a69a3815 100644
--- a/configure.ac
+++ b/configure.ac
@@ -212,6 +212,13 @@ if test "x$enable_debug" = xyes; then
AC_SUBST([DEBUG_CFLAGS])
fi
+# prevent relinking the world on every commit for developers
+AC_ARG_ENABLE(git-hash,
+ AS_HELP_STRING([--disable-git-hash],
+ [Do not use git hash in version]),
+ [git_hash=$enableval], [git_hash=yes])
+AM_CONDITIONAL(SKIP_GIT_HASH, [test "x$git_hash" = xno])
+
# -----------------------------------------------------------------------------
# To build multithread code, gcc uses -pthread, Solaris Studio cc uses -mt