summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build12
1 files changed, 6 insertions, 6 deletions
diff --git a/tests/meson.build b/tests/meson.build
index 1efeda97..191ac4ce 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -191,7 +191,6 @@ test_progs = [
'kms_vblank',
'meta_test',
'perf',
- 'perf_pmu',
'pm_backlight',
'pm_lpsp',
'pm_rc6_residency',
@@ -261,17 +260,18 @@ libexecdir = join_paths(get_option('prefix'), get_option('libexecdir'), 'intel-g
test_executables = []
foreach prog : test_progs
- link = []
- if prog == 'perf_pmu'
- link += lib_igt_perf
- endif
test_executables += executable(prog, prog + '.c',
dependencies : test_deps,
install_dir : libexecdir,
- link_with : link,
install : true)
endforeach
+test_executables += executable('perf_pmu', 'perf_pmu.c',
+ dependencies : test_deps + [ lib_igt_perf ],
+ install_dir : libexecdir,
+ install : true)
+test_progs += 'perf_pmu'
+
executable('testdisplay', ['testdisplay.c', 'testdisplay_hotplug.c'],
dependencies : test_deps,
install_dir : libexecdir,