summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Rigby <john.rigby@linaro.org>2011-09-25 21:47:58 -0600
committerLee Jones <lee.jones@linaro.org>2011-12-12 11:50:57 +0000
commit28bf982b9a585b47e00011f709a05b4e94d40ac3 (patch)
tree6993f8f9144ac6eb29cd963652d12d38b472ad6c
parent0dec40664dba25f205ef06e28092db191766451e (diff)
LINARO: fix cross compiling of tools
Signed-off-by: John Rigby <john.rigby@linaro.org>
-rw-r--r--debian/rules.d/2-binary-arch.mk7
1 files changed, 6 insertions, 1 deletions
diff --git a/debian/rules.d/2-binary-arch.mk b/debian/rules.d/2-binary-arch.mk
index 56bf93773aa..6b179d71161 100644
--- a/debian/rules.d/2-binary-arch.mk
+++ b/debian/rules.d/2-binary-arch.mk
@@ -349,7 +349,12 @@ endif
$(stampdir)/stamp-build-perarch: prepare-perarch
ifeq ($(do_tools),true)
- cd $(builddir)/tools-$*/tools/perf && make
+ cd $(builddir)/tools/tools/perf && \
+ make HAVE_CPLUS_DEMANGLE=1 CROSS_COMPILE=$(CROSS_COMPILE) $(conc_level)
+ if [ "$(arch)" = "amd64" ] || [ "$(arch)" = "i386" ]; then \
+ cd $(builddir)/tools/tools/power/x86/x86_energy_perf_policy && make CROSS_COMPILE=$(CROSS_COMPILE); \
+ cd $(builddir)/tools/tools/power/x86/turbostat && make CROSS_COMPILE=$(CROSS_COMPILE); \
+ fi
endif
@touch $@