summaryrefslogtreecommitdiff
path: root/debian/rules.d/4-checks.mk
diff options
context:
space:
mode:
authorJohn Rigby <john.rigby@linaro.org>2010-09-03 00:03:56 -0600
committerJohn Fredriksson <john.xj.fredriksson@stericsson.com>2011-10-28 16:19:03 +0200
commitc9509f78bf1644452f9ffd4fb0a7528b56b3e562 (patch)
tree77151173d941e9f2a410c4a46fdcb6413f63f38a /debian/rules.d/4-checks.mk
parent9c4cecf7de2bada874943d019010299e2e181ca3 (diff)
LINARO: Add generic linaro packaging
Signed-off-by: John Rigby <john.rigby@linaro.org>
Diffstat (limited to 'debian/rules.d/4-checks.mk')
-rw-r--r--debian/rules.d/4-checks.mk34
1 files changed, 34 insertions, 0 deletions
diff --git a/debian/rules.d/4-checks.mk b/debian/rules.d/4-checks.mk
new file mode 100644
index 00000000000..d48c05d6260
--- /dev/null
+++ b/debian/rules.d/4-checks.mk
@@ -0,0 +1,34 @@
+# Check ABI for package against last release (if not same abinum)
+abi-%: $(abidir)/%
+ @# Empty for make to be happy
+$(abidir)/%: $(stampdir)/stamp-build-%
+ install -d $(abidir)
+ sed -e 's/^\(.\+\)[[:space:]]\+\(.\+\)[[:space:]]\(.\+\)$$/\3 \2 \1/' \
+ $(builddir)/build-$*/Module.symvers | sort > $@
+
+abi-check-%: $(abidir)/%
+ @perl -f $(DROOT)/scripts/abi-check "$*" "$(prev_abinum)" "$(abinum)" \
+ "$(prev_abidir)" "$(abidir)" "$(skipabi)"
+
+# Check the module list against the last release (always)
+module-%: $(abidir)/%.modules
+ @# Empty for make to be happy
+$(abidir)/%.modules: $(stampdir)/stamp-build-%
+ install -d $(abidir)
+ find $(builddir)/build-$*/ -name \*.ko | \
+ sed -e 's/.*\/\([^\/]*\)\.ko/\1/' | sort > $@
+
+module-check-%: $(abidir)/%.modules
+ @perl -f $(DROOT)/scripts/module-check "$*" \
+ "$(prev_abidir)" "$(abidir)" $(skipmodule)
+
+checks-%: abi-check-% module-check-%
+ @# Will be calling more stuff later
+
+# Check the config against the known options list.
+config-prepare-check-%: $(stampdir)/stamp-prepare-tree-%
+ @perl -f $(DROOT)/scripts/config-check \
+ $(builddir)/build-$*/.config "$(arch)" "$*" "$(sharedconfdir)" "$(skipconfig)"
+
+prepare-checks-%: config-prepare-check-%
+ @# Will be calling more stuff later