summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules31
1 files changed, 31 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 000000000..f5864c090
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,31 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+#%:
+# dh $@
+
+#UBOOT_MAKE_ARGS := ARCH=arm CROSS_COMPILE=/usr/bin/arm-linux-gnueabi-
+UBOOT_MAKE_ARGS := ARCH=arm
+
+build:
+ $(MAKE) $(UBOOT_MAKE_ARGS) u8500_snowball_config
+ $(MAKE) $(UBOOT_MAKE_ARGS)
+
+binary:
+ $(MAKE) $(UBOOT_MAKE_ARGS) u8500_snowball_config
+ $(MAKE) $(UBOOT_MAKE_ARGS)
+
+binary-arch:
+ $(MAKE) $(UBOOT_MAKE_ARGS) u8500_snowball_config
+ $(MAKE) $(UBOOT_MAKE_ARGS)
+
+clean:
+ $(MAKE) $(UBOOT_MAKE_ARGS) clean