summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaruch Siach <baruch@tkos.co.il>2016-08-12 18:14:31 +0300
committerPeter Korsgaard <peter@korsgaard.com>2016-08-17 00:01:05 +0200
commit721bcb85132ba5842f61c6204a316d1bf04b3f49 (patch)
tree418c4aff4e5ab35e67c9d19fd68767b313b816d0
parent59472d3ba0841b7c41a08bad0f76f2c2fe5f0682 (diff)
spidev_test: fix musl build
spidev.h needs _IOC_SIZEBITS. Add linux/ioctl.h for that to fix build under musl. The patch suggested upstream (https://patchwork.kernel.org/patch/9276909/) does not apply to the spidev_test.c version we currently use. A backported patch would break once we bump spidev_test.c. A bump+patch solution would break if/when upstream accepts this patch. That's why this commit uses the unusual sed patching to keep compatibility with current and future spidev_test.c versions. Fixes: http://autobuild.buildroot.net/results/128/1284a36c70ff8a1412e2128266c6654b2aa5b2da/ http://autobuild.buildroot.net/results/0ad/0adea6121b238adf0e64d455a7573b1a31c38264/ http://autobuild.buildroot.net/results/21b/21b92651ce456f3819eef315cecd92ff70b9e98f/ Signed-off-by: Baruch Siach <baruch@tkos.co.il> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
-rw-r--r--package/spidev_test/spidev_test.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/package/spidev_test/spidev_test.mk b/package/spidev_test/spidev_test.mk
index 646372f2f..52441bb3d 100644
--- a/package/spidev_test/spidev_test.mk
+++ b/package/spidev_test/spidev_test.mk
@@ -16,6 +16,15 @@ SPIDEV_TEST_SITE = http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.gi
SPIDEV_TEST_SOURCE = spidev_test.c?id=$(SPIDEV_TEST_VERSION)
SPIDEV_TEST_LICENSE = GPLv2
+# musl libc requires linux/ioctl.h for _IOC_SIZEBITS. Do a sed patch to keep
+# compatibility with different spidev_test.c versions that we support.
+define SPIDEV_ADD_LINUX_IOCTL
+ $(SED) 's~^#include <sys/ioctl.h>~#include <sys/ioctl.h>\n#include <linux/ioctl.h>~' \
+ $(@D)/spidev_test.c
+endef
+
+SPIDEV_TEST_POST_PATCH_HOOKS += SPIDEV_ADD_LINUX_IOCTL
+
define SPIDEV_TEST_EXTRACT_CMDS
cp $(BR2_DL_DIR)/$(SPIDEV_TEST_SOURCE) $(@D)/spidev_test.c
endef