summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas De Schampheleire <thomas.de.schampheleire@gmail.com>2015-02-03 15:21:46 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-02-14 16:37:20 +0100
commit89a47724e943fe449ce55b6341d64744fcb8e18a (patch)
tree72216a2d6fd8723224a346136ddb5c10cc23ec96
parentd1f94bf403416ef3d3a9cc40dfbd8063db8f3348 (diff)
linux: qstrip the path to the custom configuration file
Even though this is not strictly necessary with the current version of linux.mk, it becomes necessary when migrating linux.mk to the kconfig infrastructure. Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Signed-off-by: "Yann E. Morin" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-rw-r--r--linux/linux.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/linux/linux.mk b/linux/linux.mk
index 29f59e882..a321fa74e 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -171,7 +171,7 @@ LINUX_POST_PATCH_HOOKS += LINUX_APPLY_PATCHES
ifeq ($(BR2_LINUX_KERNEL_USE_DEFCONFIG),y)
KERNEL_SOURCE_CONFIG = $(KERNEL_ARCH_PATH)/configs/$(call qstrip,$(BR2_LINUX_KERNEL_DEFCONFIG))_defconfig
else ifeq ($(BR2_LINUX_KERNEL_USE_CUSTOM_CONFIG),y)
-KERNEL_SOURCE_CONFIG = $(BR2_LINUX_KERNEL_CUSTOM_CONFIG_FILE)
+KERNEL_SOURCE_CONFIG = $(call qstrip,$(BR2_LINUX_KERNEL_CUSTOM_CONFIG_FILE))
endif
define LINUX_CONFIGURE_CMDS