summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2016-05-03 16:56:51 -0300
committerPeter Korsgaard <peter@korsgaard.com>2016-05-05 08:30:47 +0200
commit8b850c32541d7702163509726e0c4e02acb4d8c3 (patch)
tree01f44011f1569aaa2967d8cc8d7ef8a23c2f5cf9
parent0c956f2df9b8d2ab3909fee1b610105082974f46 (diff)
gst1-plugins-bad: add rtmp support
As pointed by sonnex on the mailing list. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
-rw-r--r--package/gstreamer1/gst1-plugins-bad/Config.in6
-rw-r--r--package/gstreamer1/gst1-plugins-bad/gst1-plugins-bad.mk7
2 files changed, 13 insertions, 0 deletions
diff --git a/package/gstreamer1/gst1-plugins-bad/Config.in b/package/gstreamer1/gst1-plugins-bad/Config.in
index 53ce589d3..facfe58dc 100644
--- a/package/gstreamer1/gst1-plugins-bad/Config.in
+++ b/package/gstreamer1/gst1-plugins-bad/Config.in
@@ -382,6 +382,12 @@ config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_REMOVESILENCE
help
Removes silence from an audio stream
+config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_RTMP
+ bool "rtmp"
+ select BR2_PACKAGE_RTMPDUMP
+ help
+ RTMP plugin
+
config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_SDI
bool "sdi"
diff --git a/package/gstreamer1/gst1-plugins-bad/gst1-plugins-bad.mk b/package/gstreamer1/gst1-plugins-bad/gst1-plugins-bad.mk
index 6d8cac7c2..e2446a3c2 100644
--- a/package/gstreamer1/gst1-plugins-bad/gst1-plugins-bad.mk
+++ b/package/gstreamer1/gst1-plugins-bad/gst1-plugins-bad.mk
@@ -479,6 +479,13 @@ else
GST1_PLUGINS_BAD_CONF_OPTS += --disable-removesilence
endif
+ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_RTMP),y)
+GST1_PLUGINS_BAD_CONF_OPTS += --enable-rtmp
+GST1_PLUGINS_BAD_DEPENDENCIES += rtmpdump
+else
+GST1_PLUGINS_BAD_CONF_OPTS += --disable-rtmp
+endif
+
ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_SDI),y)
GST1_PLUGINS_BAD_CONF_OPTS += --enable-sdi
else