summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJörg Krause <jkrause@posteo.de>2014-12-09 02:44:35 +0100
committerPeter Korsgaard <peter@korsgaard.com>2014-12-09 14:29:35 +0100
commitc492abf96e9e022d717e1902501056b7b614c388 (patch)
treea09362abad002433d303c71b433ab2051585865f
parent9289dc562d89aeca722d4b4c3b0083183c2eeaa7 (diff)
package/musl: fix C library installation directory
Set the installation path for the libraries to /lib instead of /usr/lib. This fixes an issue when building a toolchain with the musl library by the internal toolchain backend of Buildroot in the first step and import this toolchain later as a custom external toolchain in a second step. For this use case check-musl in toolchain/helpers.mk failed because it did not find the libc or libm in sysroot/lib. This patch superseeds: [PATCH 1/1] toolchain/helpers.mk: fix check-musl http://patchwork.ozlabs.org/patch/417587/ Signed-off-by: Jörg Krause <jkrause@posteo.de> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
-rw-r--r--package/musl/musl.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/musl/musl.mk b/package/musl/musl.mk
index fb4327da6..3a45575a1 100644
--- a/package/musl/musl.mk
+++ b/package/musl/musl.mk
@@ -27,6 +27,7 @@ define MUSL_CONFIGURE_CMDS
--target=$(GNU_TARGET_NAME) \
--host=$(GNU_TARGET_NAME) \
--prefix=/usr \
+ --libdir=/lib \
--disable-gcc-wrapper)
endef