summaryrefslogtreecommitdiff
path: root/linux/linux.mk
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2014-10-21 18:10:51 -0300
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-01-10 18:45:15 +0100
commit2cbda5b6746772be7842fed40d01d61f9f2116b0 (patch)
tree06d1a5465fad8fb17ab76ba680623d6e3292ff33 /linux/linux.mk
parent490917387a0ff6969f8130be38993eed5f06f73e (diff)
iptables: enable basic kernel options
Enable the basic kernel options for iptables to be useful at least to filter incoming connections. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'linux/linux.mk')
-rw-r--r--linux/linux.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/linux/linux.mk b/linux/linux.mk
index 825664167..a3efbb2b6 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -212,6 +212,11 @@ define LINUX_CONFIGURE_CMDS
$(call KCONFIG_ENABLE_OPT,CONFIG_SECURITY,$(@D)/.config)
$(call KCONFIG_ENABLE_OPT,CONFIG_SECURITY_SMACK,$(@D)/.config)
$(call KCONFIG_ENABLE_OPT,CONFIG_SECURITY_NETWORK,$(@D)/.config))
+ $(if $(BR2_PACKAGE_IPTABLES),
+ $(call KCONFIG_ENABLE_OPT,CONFIG_IP_NF_IPTABLES,$(@D)/.config)
+ $(call KCONFIG_ENABLE_OPT,CONFIG_IP_NF_FILTER,$(@D)/.config)
+ $(call KCONFIG_ENABLE_OPT,CONFIG_NETFILTER,$(@D)/.config)
+ $(call KCONFIG_ENABLE_OPT,CONFIG_NETFILTER_XTABLES,$(@D)/.config))
$(if $(BR2_LINUX_KERNEL_APPENDED_DTB),
$(call KCONFIG_ENABLE_OPT,CONFIG_ARM_APPENDED_DTB,$(@D)/.config))
yes '' | $(TARGET_MAKE_ENV) $(MAKE1) $(LINUX_MAKE_FLAGS) -C $(@D) oldconfig