summaryrefslogtreecommitdiff
path: root/linux/linux.mk
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2015-03-13 19:57:28 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-03-13 22:04:29 +0100
commit68443c52dd871ec157aff6b3f77bed1294c2eb57 (patch)
treee50ed5a55bdf7838ea5d75a4e764a7637532f265 /linux/linux.mk
parent9ebae47f299abf5fe749897d3cafa82f9ff15bbc (diff)
linux: add note about why it's safe to include other .mk files
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Cc: Thomas De Schampheleire <patrickdepinguin@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'linux/linux.mk')
-rw-r--r--linux/linux.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/linux/linux.mk b/linux/linux.mk
index 5afcd4e78..b1aca419d 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -323,6 +323,14 @@ define LINUX_INSTALL_TARGET_CMDS
$(LINUX_INSTALL_HOST_TOOLS)
endef
+# Note: our package infrastructure uses the full-path of the last-scanned
+# Makefile to determine what package we're currently defining, using the
+# last directory component in the path. As such, including other Makefile,
+# like below, before we call one of the *-package macro is usally not
+# working.
+# However, since the files we include here are in the same directory as
+# the current Makefile, we are OK. But this is a hard requirement: files
+# included here *must* be in the same directory!
include $(sort $(wildcard linux/linux-ext-*.mk))
$(eval $(kconfig-package))