summaryrefslogtreecommitdiff
path: root/linux/linux.mk
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-02-22 14:39:00 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-07-13 18:26:58 +0200
commit90d008ea7ab4fe0cf8e17b27b978bc367edfd8c0 (patch)
tree2f2fc0d88a89f3b4011e4534e09231c26c77ea9b /linux/linux.mk
parent4ab06dd1e95abf1b9c8b0ee38bae25b8a305b5e8 (diff)
linux: adjust fixup logic for ktap
The ktap package requires some parts of the kernel tracing infrastructure to be enabled, especially CONFIG_EVENT_TRACING. However, this option is a blind option in the kernel, so enabling it in linux.mk has no effect: we need to enable a non-blind option that selects CONFIG_EVENT_TRACING. We've chosen to select CONFIG_ENABLE_DEFAULT_TRACERS. This fixes the build of ktap. [Thomas: use CONFIG_ENABLE_DEFAULT_TRACERS as suggested by Arnout.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Diffstat (limited to 'linux/linux.mk')
-rw-r--r--linux/linux.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/linux/linux.mk b/linux/linux.mk
index eca1450d5..b602a0408 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -207,7 +207,7 @@ define LINUX_KCONFIG_FIXUP_CMDS
$(call KCONFIG_ENABLE_OPT,CONFIG_INOTIFY_USER,$(@D)/.config))
$(if $(BR2_PACKAGE_KTAP),
$(call KCONFIG_ENABLE_OPT,CONFIG_DEBUG_FS,$(@D)/.config)
- $(call KCONFIG_ENABLE_OPT,CONFIG_EVENT_TRACING,$(@D)/.config)
+ $(call KCONFIG_ENABLE_OPT,CONFIG_ENABLE_DEFAULT_TRACERS,$(@D)/.config)
$(call KCONFIG_ENABLE_OPT,CONFIG_PERF_EVENTS,$(@D)/.config)
$(call KCONFIG_ENABLE_OPT,CONFIG_FUNCTION_TRACER,$(@D)/.config))
$(if $(BR2_PACKAGE_SYSTEMD),