summaryrefslogtreecommitdiff
path: root/linux/linux.mk
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2015-07-13 12:31:59 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-07-14 10:26:31 +0200
commitce2b7face01acab42e67c5ddf9f075445fe77693 (patch)
treea8f2eb8b13692fd04fd41bfca97d08a96bf42fea /linux/linux.mk
parent61ca162f5bf052f70c6ac356358120329e4b1c6d (diff)
package/linux: don't enforce check for DTS when not building
Currently, this is triggering the error message: make randconfig make source Limit the checks that enforce a DTS is set and at most one DTB is appended to when we are actually building, like is done for the configuration-file variables. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'linux/linux.mk')
-rw-r--r--linux/linux.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/linux/linux.mk b/linux/linux.mk
index b602a0408..cd32652b6 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -88,6 +88,8 @@ else ifeq ($(BR2_LINUX_KERNEL_USE_CUSTOM_DTS),y)
KERNEL_DTS_NAME = $(basename $(filter %.dts,$(notdir $(call qstrip,$(BR2_LINUX_KERNEL_CUSTOM_DTS_PATH)))))
endif
+ifeq ($(BR_BUILDING),y)
+
ifeq ($(BR2_LINUX_KERNEL_DTS_SUPPORT)$(KERNEL_DTS_NAME),y)
$(error No kernel device tree source specified, check your \
BR2_LINUX_KERNEL_USE_INTREE_DTS / BR2_LINUX_KERNEL_USE_CUSTOM_DTS settings)
@@ -100,6 +102,8 @@ $(error Kernel with appended device tree needs exactly one DTS source. \
endif
endif
+endif # BR_BUILDING
+
KERNEL_DTBS = $(addsuffix .dtb,$(KERNEL_DTS_NAME))
ifeq ($(BR2_LINUX_KERNEL_IMAGE_TARGET_CUSTOM),y)