summaryrefslogtreecommitdiff
path: root/linux/linux.mk
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2014-10-21 18:10:52 -0300
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-01-10 18:45:23 +0100
commite5d715dda5b42e15ae3526c111d26307c9f13638 (patch)
treefbca884dd8d72735fbbc4c0364d0a33a08f14abf /linux/linux.mk
parent2cbda5b6746772be7842fed40d01d61f9f2116b0 (diff)
xtables-addons: enable necessary kernel options
Enable the required conntrack/netfilter options, otherwise xtables-addons will fail to build. The basic iptables options are already covered by the iptables package which is a required dependency anyway. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'linux/linux.mk')
-rw-r--r--linux/linux.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/linux/linux.mk b/linux/linux.mk
index a3efbb2b6..680521c55 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -217,6 +217,9 @@ define LINUX_CONFIGURE_CMDS
$(call KCONFIG_ENABLE_OPT,CONFIG_IP_NF_FILTER,$(@D)/.config)
$(call KCONFIG_ENABLE_OPT,CONFIG_NETFILTER,$(@D)/.config)
$(call KCONFIG_ENABLE_OPT,CONFIG_NETFILTER_XTABLES,$(@D)/.config))
+ $(if $(BR2_PACKAGE_XTABLES_ADDONS),
+ $(call KCONFIG_ENABLE_OPT,CONFIG_NF_CONNTRACK,$(@D)/.config)
+ $(call KCONFIG_ENABLE_OPT,CONFIG_NF_CONNTRACK_MARK,$(@D)/.config))
$(if $(BR2_LINUX_KERNEL_APPENDED_DTB),
$(call KCONFIG_ENABLE_OPT,CONFIG_ARM_APPENDED_DTB,$(@D)/.config))
yes '' | $(TARGET_MAKE_ENV) $(MAKE1) $(LINUX_MAKE_FLAGS) -C $(@D) oldconfig