summaryrefslogtreecommitdiff
path: root/linux
diff options
context:
space:
mode:
authorArnout Vandecappelle <arnout@mind.be>2015-07-12 16:35:27 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-07-15 00:42:01 +0200
commit28f57bb863ba48df054cec0057c844bf23d5969f (patch)
tree0d051f7fc7b0a0c69e326c03328e31721c65e8ff /linux
parent7d69a79624b1f338950cd6cc650e029dd4d4b91a (diff)
linux: use backtick instead of $(shell ...) make function
Verified that LINUX_VERSION_PROBED is only used in "-quoted commands (actually, usually it's not quoted). Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'linux')
-rw-r--r--linux/linux.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/linux/linux.mk b/linux/linux.mk
index 3ea564f56..375a9e1e1 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -76,7 +76,7 @@ LINUX_MAKE_ENV = \
# Get the real Linux version, which tells us where kernel modules are
# going to be installed in the target filesystem.
-LINUX_VERSION_PROBED = $(shell $(MAKE) $(LINUX_MAKE_FLAGS) -C $(LINUX_DIR) --no-print-directory -s kernelrelease)
+LINUX_VERSION_PROBED = `$(MAKE) $(LINUX_MAKE_FLAGS) -C $(LINUX_DIR) --no-print-directory -s kernelrelease`
ifeq ($(BR2_LINUX_KERNEL_USE_INTREE_DTS),y)
KERNEL_DTS_NAME = $(call qstrip,$(BR2_LINUX_KERNEL_INTREE_DTS_NAME))