summaryrefslogtreecommitdiff
path: root/linux
diff options
context:
space:
mode:
authorArnout Vandecappelle <arnout@mind.be>2015-10-04 17:28:15 +0100
committerPeter Korsgaard <peter@korsgaard.com>2015-10-05 16:01:32 +0200
commit55a6b6d0d189fbb91555aeebc054e0ae97d113a7 (patch)
treefe6b1a7ac791f0833121149c42ceb99dae748f6d /linux
parent7e693a0734644ceb79b7b90c65b227fd0d73bf21 (diff)
linux: add 'Image' as the image name for aarch64
On aarch64, the image name is always Image, so let's add support for that. Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'linux')
-rw-r--r--linux/Config.in4
-rw-r--r--linux/linux.mk2
2 files changed, 6 insertions, 0 deletions
diff --git a/linux/Config.in b/linux/Config.in
index bb4f86b7c..99c8a0ed5 100644
--- a/linux/Config.in
+++ b/linux/Config.in
@@ -225,6 +225,10 @@ config BR2_LINUX_KERNEL_SIMPLEIMAGE
select BR2_LINUX_KERNEL_DTS_SUPPORT
select BR2_LINUX_KERNEL_DTB_IS_SELF_BUILT
+config BR2_LINUX_KERNEL_IMAGE
+ bool "Image"
+ depends on BR2_aarch64
+
config BR2_LINUX_KERNEL_LINUX_BIN
bool "linux.bin"
depends on BR2_microblaze
diff --git a/linux/linux.mk b/linux/linux.mk
index c98459f33..6c7ecfcc9 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -111,6 +111,8 @@ else ifeq ($(BR2_LINUX_KERNEL_CUIMAGE),y)
LINUX_IMAGE_NAME = cuImage.$(KERNEL_DTS_NAME)
else ifeq ($(BR2_LINUX_KERNEL_SIMPLEIMAGE),y)
LINUX_IMAGE_NAME = simpleImage.$(KERNEL_DTS_NAME)
+else ifeq ($(BR2_LINUX_KERNEL_IMAGE),y)
+LINUX_IMAGE_NAME = Image
else ifeq ($(BR2_LINUX_KERNEL_LINUX_BIN),y)
LINUX_IMAGE_NAME = linux.bin
else ifeq ($(BR2_LINUX_KERNEL_VMLINUX_BIN),y)