summaryrefslogtreecommitdiff
path: root/linux
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2015-05-02 11:05:06 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-05-02 15:11:01 +0200
commit715ebe3b4d1702420e32b93750f03a2318d22040 (patch)
treea5bea2fdb222aea3f5228a043d8e51cd304c03be /linux
parentf95a59c3a0a32ff0259d5d3fb31d9b1068bbc9b3 (diff)
linux: do not check hashes for custom versions and tarballs
This one is a bit tricky, as the version can come from the linux-headers package, so we must also account for that. We currently have no hash file for linux, but better do the change now, which allows us to later add a hash file. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Cc: Arnout Vandecappelle <arnout@mind.be> Reviewed-by: Arnout Vandecappelle <arnout@mind.be> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'linux')
-rw-r--r--linux/linux.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/linux/linux.mk b/linux/linux.mk
index 0c348dae9..c76595407 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -13,6 +13,7 @@ ifeq ($(BR2_LINUX_KERNEL_CUSTOM_TARBALL),y)
LINUX_TARBALL = $(call qstrip,$(BR2_LINUX_KERNEL_CUSTOM_TARBALL_LOCATION))
LINUX_SITE = $(patsubst %/,%,$(dir $(LINUX_TARBALL)))
LINUX_SOURCE = $(notdir $(LINUX_TARBALL))
+BR_NO_CHECK_HASH_FOR += $(LINUX_SOURCE)
else ifeq ($(BR2_LINUX_KERNEL_CUSTOM_LOCAL),y)
LINUX_SITE = $(call qstrip,$(BR2_LINUX_KERNEL_CUSTOM_LOCAL_PATH))
LINUX_SITE_METHOD = local
@@ -24,6 +25,12 @@ LINUX_SITE = $(call qstrip,$(BR2_LINUX_KERNEL_CUSTOM_REPO_URL))
LINUX_SITE_METHOD = hg
else
LINUX_SOURCE = linux-$(LINUX_VERSION).tar.xz
+ifeq ($(BR2_LINUX_KERNEL_CUSTOM_VERSION),y)
+BR_NO_CHECK_HASH_FOR += $(LINUX_SOURCE)
+endif
+ifeq ($(BR2_LINUX_KERNEL_SAME_AS_HEADERS)$(BR2_KERNEL_HEADERS_VERSION),yy)
+BR_NO_CHECK_HASH_FOR += $(LINUX_SOURCE)
+endif
# In X.Y.Z, get X and Y. We replace dots and dashes by spaces in order
# to use the $(word) function. We support versions such as 4.0, 3.1,
# 2.6.32, 2.6.32-rc1, 3.0-rc6, etc.