summaryrefslogtreecommitdiff
path: root/linux
diff options
context:
space:
mode:
authorEric Le Bihan <eric.le.bihan.dev@free.fr>2014-04-20 20:54:03 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-04-21 12:15:45 +0200
commit773ee9797ad4c74e967ad959f6ce0677b6c66677 (patch)
treed0596a4f0697b13232b5b55c05c7fbbb54bb1cb2 /linux
parent57155c6b6a7a40523075626353375109fe159c04 (diff)
smack: new package.
SMACK stands for Simplified Mandatory Access Control Kernel. It is a Linux Security Module which provides a Mandatory Access Control mechanism, like SELinux, but aiming towards simplicity. This package provides the tools to load/unload the policy from the kernel as well as a library allowing applications to interact with SMACK. The proper kernel options are also set. [Thomas: - fixed license to be LGPLv2.1 instead of LGPLv2.1+. Even though the debian/copyright file has the "or later" indication, none of the .c source files carry it, so I suppose LGPLv2.1 is more correct. - added !BR2_PREFER_STATIC_LIB dependency. - added dependency on host-pkgconf, since Smack configure.ac uses PKG_CHECK_MODULES.] Signed-off-by: Eric Le Bihan <eric.le.bihan.dev@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'linux')
-rw-r--r--linux/linux.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/linux/linux.mk b/linux/linux.mk
index e27070569..bd3f2ac29 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -200,6 +200,10 @@ define LINUX_CONFIGURE_CMDS
$(call KCONFIG_ENABLE_OPT,CONFIG_AUTOFS4_FS,$(@D)/.config)
$(call KCONFIG_ENABLE_OPT,CONFIG_TMPFS_POSIX_ACL,$(@D)/.config)
$(call KCONFIG_ENABLE_OPT,CONFIG_TMPFS_POSIX_XATTR,$(@D)/.config))
+ $(if $(BR2_PACKAGE_SMACK),
+ $(call KCONFIG_ENABLE_OPT,CONFIG_SECURITY,$(@D)/.config)
+ $(call KCONFIG_ENABLE_OPT,CONFIG_SECURITY_SMACK,$(@D)/.config)
+ $(call KCONFIG_ENABLE_OPT,CONFIG_SECURITY_NETWORK,$(@D)/.config))
$(if $(BR2_LINUX_KERNEL_APPENDED_DTB),
$(call KCONFIG_ENABLE_OPT,CONFIG_ARM_APPENDED_DTB,$(@D)/.config))
yes '' | $(TARGET_MAKE_ENV) $(MAKE1) $(LINUX_MAKE_FLAGS) -C $(@D) oldconfig