summaryrefslogtreecommitdiff
path: root/linux
diff options
context:
space:
mode:
authorFloris Bos <bos@je-eigen-domein.nl>2015-04-28 16:34:32 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-05-21 23:42:48 +0200
commit87bd1e3724d6ffbe868a6c38fdb2b56ae20cabbd (patch)
tree446d42c98dc949646802c440c44e4ddd768764ad /linux
parent0cfb5549b37f7072cb49c984743b0dd4b9e0bea9 (diff)
linux: add option to specify config fragments
Signed-off-by: Floris Bos <bos@je-eigen-domein.nl> Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Tested-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Tested-by: Gergely Imreh <imrehg@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'linux')
-rw-r--r--linux/Config.in6
-rw-r--r--linux/linux.mk1
2 files changed, 7 insertions, 0 deletions
diff --git a/linux/Config.in b/linux/Config.in
index f2d46522d..30e38e45d 100644
--- a/linux/Config.in
+++ b/linux/Config.in
@@ -164,6 +164,12 @@ config BR2_LINUX_KERNEL_CUSTOM_CONFIG_FILE
Note: this can be a defconfig file or a complete .config file,
which can later be saved back with make linux-update-(def)config.
+config BR2_LINUX_KERNEL_CONFIG_FRAGMENT_FILES
+ string "Additional configuration fragment files"
+ help
+ A space-separated list of kernel configuration fragment files,
+ that will be merged to the main kernel configuration file.
+
#
# Binary format
#
diff --git a/linux/linux.mk b/linux/linux.mk
index c76595407..eca1450d5 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -182,6 +182,7 @@ KERNEL_SOURCE_CONFIG = $(call qstrip,$(BR2_LINUX_KERNEL_CUSTOM_CONFIG_FILE))
endif
LINUX_KCONFIG_FILE = $(KERNEL_SOURCE_CONFIG)
+LINUX_KCONFIG_FRAGMENT_FILES = $(call qstrip,$(BR2_LINUX_KERNEL_CONFIG_FRAGMENT_FILES))
LINUX_KCONFIG_EDITORS = menuconfig xconfig gconfig nconfig
LINUX_KCONFIG_OPTS = $(LINUX_MAKE_FLAGS)