summaryrefslogtreecommitdiff
path: root/linux
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2015-07-22 16:58:53 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-07-22 17:25:25 +0200
commitc95dc64c294614c1d9bebb0931301b30abaaca26 (patch)
treefd860ca087170306dd094e1bd39789f845424a0f /linux
parent273031ca02459efa430bf2b8ff3ca0dd9232d99a (diff)
package/linux: trash stderr in LINUX_VERSION_PROBED
The Linux buildsystem tries to run the compiler even just for 'kernelrelease' (which we store in LINUX_VERSION_PROBED) and we sometimes need to use it before the toolchain is available; thus we get spurious errors on stderr. Consign stderr to oblivion when computing the 'kernelrelease'. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'linux')
-rw-r--r--linux/linux.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/linux/linux.mk b/linux/linux.mk
index 375a9e1e1..d91dbb2df 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -76,7 +76,7 @@ LINUX_MAKE_ENV = \
# Get the real Linux version, which tells us where kernel modules are
# going to be installed in the target filesystem.
-LINUX_VERSION_PROBED = `$(MAKE) $(LINUX_MAKE_FLAGS) -C $(LINUX_DIR) --no-print-directory -s kernelrelease`
+LINUX_VERSION_PROBED = `$(MAKE) $(LINUX_MAKE_FLAGS) -C $(LINUX_DIR) --no-print-directory -s kernelrelease 2>/dev/null`
ifeq ($(BR2_LINUX_KERNEL_USE_INTREE_DTS),y)
KERNEL_DTS_NAME = $(call qstrip,$(BR2_LINUX_KERNEL_INTREE_DTS_NAME))