summaryrefslogtreecommitdiff
path: root/linux
diff options
context:
space:
mode:
authorPeter Korsgaard <peter@korsgaard.com>2015-06-01 23:52:57 +0200
committerPeter Korsgaard <peter@korsgaard.com>2015-06-01 23:52:57 +0200
commitcddaae8229f69aba753bcb6603f2f1e395e4f8dd (patch)
tree32d8ef5448083d487c4358ba035af797927038f3 /linux
parent841d3ac7e04fe3c2d8f4ccbc063db5650ec4779e (diff)
parent9b6a122841664ec8bea2b84e585adb3528909227 (diff)
Merge branch 'next'
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'linux')
-rw-r--r--linux/Config.in6
-rw-r--r--linux/linux.mk1
2 files changed, 7 insertions, 0 deletions
diff --git a/linux/Config.in b/linux/Config.in
index 457ada65c..b5640850f 100644
--- a/linux/Config.in
+++ b/linux/Config.in
@@ -164,6 +164,12 @@ config BR2_LINUX_KERNEL_CUSTOM_CONFIG_FILE
Note: this can be a defconfig file or a complete .config file,
which can later be saved back with make linux-update-(def)config.
+config BR2_LINUX_KERNEL_CONFIG_FRAGMENT_FILES
+ string "Additional configuration fragment files"
+ help
+ A space-separated list of kernel configuration fragment files,
+ that will be merged to the main kernel configuration file.
+
#
# Binary format
#
diff --git a/linux/linux.mk b/linux/linux.mk
index c76595407..eca1450d5 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -182,6 +182,7 @@ KERNEL_SOURCE_CONFIG = $(call qstrip,$(BR2_LINUX_KERNEL_CUSTOM_CONFIG_FILE))
endif
LINUX_KCONFIG_FILE = $(KERNEL_SOURCE_CONFIG)
+LINUX_KCONFIG_FRAGMENT_FILES = $(call qstrip,$(BR2_LINUX_KERNEL_CONFIG_FRAGMENT_FILES))
LINUX_KCONFIG_EDITORS = menuconfig xconfig gconfig nconfig
LINUX_KCONFIG_OPTS = $(LINUX_MAKE_FLAGS)