summaryrefslogtreecommitdiff
path: root/linux
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-04-26 11:51:15 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-04-26 21:43:25 +0200
commitfa6289bb1aad1a8b6721fbeb15d34520c84dcb39 (patch)
tree3ca90cb1d78a38f1ffb920f7185657b84fa12212 /linux
parent256f142bf662fd8fee712e38edd58bb6e8fd283d (diff)
packages: refactor checks using BR_BUILDING
Instead of manually testing MAKECMDGOALS, use the newly introduced BR_BUILDING variable to know if we're building or not. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Tested-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Diffstat (limited to 'linux')
-rw-r--r--linux/linux.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/linux/linux.mk b/linux/linux.mk
index deed073e5..0c348dae9 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -354,7 +354,7 @@ $(LINUX_DIR)/.stamp_initramfs_rebuilt: $(LINUX_DIR)/.stamp_target_installed $(LI
linux-rebuild-with-initramfs: $(LINUX_DIR)/.stamp_initramfs_rebuilt
# Checks to give errors that the user can understand
-ifeq ($(filter source,$(MAKECMDGOALS)),)
+ifeq ($(BR_BUILDING),y)
ifeq ($(BR2_LINUX_KERNEL_USE_DEFCONFIG),y)
ifeq ($(call qstrip,$(BR2_LINUX_KERNEL_DEFCONFIG)),)
$(error No kernel defconfig name specified, check your BR2_LINUX_KERNEL_DEFCONFIG setting)