summaryrefslogtreecommitdiff
path: root/package/gstreamer/gst-dsp
diff options
context:
space:
mode:
authorJérôme Pouiller <jezz@sysmic.org>2013-08-30 11:05:57 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2013-09-08 21:41:39 +0200
commitadf6511013b8921d6856f5dc0e053cdd27891244 (patch)
tree14f1ba25f8ae138743e3f3954b85883c636714d8 /package/gstreamer/gst-dsp
parentbafa8fcc6ce90553843b5c24e68de57c40f94abe (diff)
Remove multimedia subdirectory
Unless it was a group of sub-packages, packages was never regrouped by category. multimedia/ was an exception to this rule. This patch move packages/multimedia/ sub-directories to packages/. It keeps two subdirectories for gstream 0.10 and gstreamer 1.X. Signed-off-by: Jérôme Pouiller <jezz@sysmic.org> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/gstreamer/gst-dsp')
-rw-r--r--package/gstreamer/gst-dsp/Config.in8
-rw-r--r--package/gstreamer/gst-dsp/gst-dsp.mk24
2 files changed, 32 insertions, 0 deletions
diff --git a/package/gstreamer/gst-dsp/Config.in b/package/gstreamer/gst-dsp/Config.in
new file mode 100644
index 000000000..590931af7
--- /dev/null
+++ b/package/gstreamer/gst-dsp/Config.in
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_GST_DSP
+ bool "gst-dsp"
+ depends on BR2_PACKAGE_GSTREAMER && BR2_cortex_a8
+ select BR2_PACKAGE_TIDSP_BINARIES
+ help
+ GStreamer plug-in to access TI OMAP3 DSP algorithms.
+
+ http://code.google.com/p/gst-dsp/
diff --git a/package/gstreamer/gst-dsp/gst-dsp.mk b/package/gstreamer/gst-dsp/gst-dsp.mk
new file mode 100644
index 000000000..1fd697607
--- /dev/null
+++ b/package/gstreamer/gst-dsp/gst-dsp.mk
@@ -0,0 +1,24 @@
+################################################################################
+#
+# gst-dsp
+#
+################################################################################
+
+GST_DSP_VERSION = 0.10.2
+GST_DSP_SITE = http://gst-dsp.googlecode.com/files/
+
+define GST_DSP_BUILD_CMDS
+ $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) -e
+endef
+
+define GST_DSP_INSTALL_TARGET_CMDS
+ $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) -e DESTDIR=$(TARGET_DIR) install
+endef
+
+define GST_DSP_UNINSTALL_TARGET_CMDS
+ $(RM) $(TARGET_DIR)/usr/lib/gstreamer-0.10/libgstdsp.so
+endef
+
+GST_DSP_DEPENDENCIES = gstreamer tidsp-binaries host-pkgconf
+
+$(eval $(generic-package))