summaryrefslogtreecommitdiff
path: root/package/gstreamer/gst-plugins-bad
diff options
context:
space:
mode:
authorThomas De Schampheleire <patrickdepinguin@gmail.com>2014-09-27 21:32:44 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-10-04 18:54:16 +0200
commitaaffd209fae91a733fe0becb72268f87bf4ea369 (patch)
tree40569895ef8a09c605060e2164d86567a12f9889 /package/gstreamer/gst-plugins-bad
parent1d2574ac6f6d30044ee138b6235c50a6a3998d8a (diff)
packages: rename FOO_CONF_OPT into FOO_CONF_OPTS
To be consistent with the recent change of FOO_MAKE_OPT into FOO_MAKE_OPTS, make the same change for FOO_CONF_OPT. Sed command used: find * -type f | xargs sed -i 's#_CONF_OPT\>#&S#g' Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/gstreamer/gst-plugins-bad')
-rw-r--r--package/gstreamer/gst-plugins-bad/gst-plugins-bad.mk366
1 files changed, 183 insertions, 183 deletions
diff --git a/package/gstreamer/gst-plugins-bad/gst-plugins-bad.mk b/package/gstreamer/gst-plugins-bad/gst-plugins-bad.mk
index 337f7566f..241399554 100644
--- a/package/gstreamer/gst-plugins-bad/gst-plugins-bad.mk
+++ b/package/gstreamer/gst-plugins-bad/gst-plugins-bad.mk
@@ -8,7 +8,7 @@ GST_PLUGINS_BAD_VERSION = 0.10.23
GST_PLUGINS_BAD_SOURCE = gst-plugins-bad-$(GST_PLUGINS_BAD_VERSION).tar.xz
GST_PLUGINS_BAD_SITE = http://gstreamer.freedesktop.org/src/gst-plugins-bad
-GST_PLUGINS_BAD_CONF_OPT = \
+GST_PLUGINS_BAD_CONF_OPTS = \
--disable-examples
GST_PLUGINS_BAD_DEPENDENCIES = gst-plugins-base gstreamer
@@ -18,564 +18,564 @@ GST_PLUGINS_BAD_DEPENDENCIES += orc
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_ADPCMDEC),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-adpcmdec
+GST_PLUGINS_BAD_CONF_OPTS += --enable-adpcmdec
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-adpcmdec
+GST_PLUGINS_BAD_CONF_OPTS += --disable-adpcmdec
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_ADPCMENC),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-adpcmenc
+GST_PLUGINS_BAD_CONF_OPTS += --enable-adpcmenc
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-adpcmenc
+GST_PLUGINS_BAD_CONF_OPTS += --disable-adpcmenc
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_AIFF),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-aiff
+GST_PLUGINS_BAD_CONF_OPTS += --enable-aiff
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-aiff
+GST_PLUGINS_BAD_CONF_OPTS += --disable-aiff
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_ASFMUX),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-asfmux
+GST_PLUGINS_BAD_CONF_OPTS += --enable-asfmux
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-asfmux
+GST_PLUGINS_BAD_CONF_OPTS += --disable-asfmux
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_AUDIOVISUALIZERS),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-audiovisualizers
+GST_PLUGINS_BAD_CONF_OPTS += --enable-audiovisualizers
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-audiovisualizers
+GST_PLUGINS_BAD_CONF_OPTS += --disable-audiovisualizers
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_AUTOCONVERT),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-autoconvert
+GST_PLUGINS_BAD_CONF_OPTS += --enable-autoconvert
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-autoconvert
+GST_PLUGINS_BAD_CONF_OPTS += --disable-autoconvert
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_BAYER),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-bayer
+GST_PLUGINS_BAD_CONF_OPTS += --enable-bayer
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-bayer
+GST_PLUGINS_BAD_CONF_OPTS += --disable-bayer
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_CAMERABIN),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-camerabin
+GST_PLUGINS_BAD_CONF_OPTS += --enable-camerabin
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-camerabin
+GST_PLUGINS_BAD_CONF_OPTS += --disable-camerabin
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_CAMERABIN2),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-camerabin2
+GST_PLUGINS_BAD_CONF_OPTS += --enable-camerabin2
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-camerabin2
+GST_PLUGINS_BAD_CONF_OPTS += --disable-camerabin2
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_CDXAPARSE),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-cdxaparse
+GST_PLUGINS_BAD_CONF_OPTS += --enable-cdxaparse
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-cdxaparse
+GST_PLUGINS_BAD_CONF_OPTS += --disable-cdxaparse
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_COLOREFFECTS),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-coloreffects
+GST_PLUGINS_BAD_CONF_OPTS += --enable-coloreffects
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-coloreffects
+GST_PLUGINS_BAD_CONF_OPTS += --disable-coloreffects
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_COLORSPACE),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-colorspace
+GST_PLUGINS_BAD_CONF_OPTS += --enable-colorspace
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-colorspace
+GST_PLUGINS_BAD_CONF_OPTS += --disable-colorspace
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_DATAURISRC),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-dataurisrc
+GST_PLUGINS_BAD_CONF_OPTS += --enable-dataurisrc
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-dataurisrc
+GST_PLUGINS_BAD_CONF_OPTS += --disable-dataurisrc
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_DCCP),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-dccp
+GST_PLUGINS_BAD_CONF_OPTS += --enable-dccp
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-dccp
+GST_PLUGINS_BAD_CONF_OPTS += --disable-dccp
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_DEBUGUTILS),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-debugutils
+GST_PLUGINS_BAD_CONF_OPTS += --enable-debugutils
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-debugutils
+GST_PLUGINS_BAD_CONF_OPTS += --disable-debugutils
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_DECKLINK),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-decklink
+GST_PLUGINS_BAD_CONF_OPTS += --enable-decklink
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-decklink
+GST_PLUGINS_BAD_CONF_OPTS += --disable-decklink
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_DTMF),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-dtmf
+GST_PLUGINS_BAD_CONF_OPTS += --enable-dtmf
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-dtmf
+GST_PLUGINS_BAD_CONF_OPTS += --disable-dtmf
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_DVBSUBOVERLAY),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-dvbsuboverlay
+GST_PLUGINS_BAD_CONF_OPTS += --enable-dvbsuboverlay
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-dvbsuboverlay
+GST_PLUGINS_BAD_CONF_OPTS += --disable-dvbsuboverlay
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_DVDSPU),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-dvdspu
+GST_PLUGINS_BAD_CONF_OPTS += --enable-dvdspu
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-dvdspu
+GST_PLUGINS_BAD_CONF_OPTS += --disable-dvdspu
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_FACEOVERLAY),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-faceoverlay
+GST_PLUGINS_BAD_CONF_OPTS += --enable-faceoverlay
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-faceoverlay
+GST_PLUGINS_BAD_CONF_OPTS += --disable-faceoverlay
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_FESTIVAL),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-festival
+GST_PLUGINS_BAD_CONF_OPTS += --enable-festival
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-festival
+GST_PLUGINS_BAD_CONF_OPTS += --disable-festival
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_FIELDANALYSIS),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-fieldanalysis
+GST_PLUGINS_BAD_CONF_OPTS += --enable-fieldanalysis
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-fieldanalysis
+GST_PLUGINS_BAD_CONF_OPTS += --disable-fieldanalysis
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_FREEZE),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-freeze
+GST_PLUGINS_BAD_CONF_OPTS += --enable-freeze
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-freeze
+GST_PLUGINS_BAD_CONF_OPTS += --disable-freeze
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_FREEVERB),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-freeverb
+GST_PLUGINS_BAD_CONF_OPTS += --enable-freeverb
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-freeverb
+GST_PLUGINS_BAD_CONF_OPTS += --disable-freeverb
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_FREI0R),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-frei0r
+GST_PLUGINS_BAD_CONF_OPTS += --enable-frei0r
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-frei0r
+GST_PLUGINS_BAD_CONF_OPTS += --disable-frei0r
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_GAUDIEFFECTS),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-gaudieffects
+GST_PLUGINS_BAD_CONF_OPTS += --enable-gaudieffects
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-gaudieffects
+GST_PLUGINS_BAD_CONF_OPTS += --disable-gaudieffects
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_GEOMETRICTRANSFORM),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-geometrictransform
+GST_PLUGINS_BAD_CONF_OPTS += --enable-geometrictransform
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-geometrictransform
+GST_PLUGINS_BAD_CONF_OPTS += --disable-geometrictransform
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_GSETTINGS),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-gsettings
+GST_PLUGINS_BAD_CONF_OPTS += --enable-gsettings
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-gsettings
+GST_PLUGINS_BAD_CONF_OPTS += --disable-gsettings
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_H264PARSE),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-h264parse
+GST_PLUGINS_BAD_CONF_OPTS += --enable-h264parse
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-h264parse
+GST_PLUGINS_BAD_CONF_OPTS += --disable-h264parse
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_HDVPARSE),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-hdvparse
+GST_PLUGINS_BAD_CONF_OPTS += --enable-hdvparse
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-hdvparse
+GST_PLUGINS_BAD_CONF_OPTS += --disable-hdvparse
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_HLS),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-hls
+GST_PLUGINS_BAD_CONF_OPTS += --enable-hls
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-hls
+GST_PLUGINS_BAD_CONF_OPTS += --disable-hls
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_ID3TAG),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-id3tag
+GST_PLUGINS_BAD_CONF_OPTS += --enable-id3tag
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-id3tag
+GST_PLUGINS_BAD_CONF_OPTS += --disable-id3tag
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_INTER),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-inter
+GST_PLUGINS_BAD_CONF_OPTS += --enable-inter
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-inter
+GST_PLUGINS_BAD_CONF_OPTS += --disable-inter
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_INTERLACE),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-interlace
+GST_PLUGINS_BAD_CONF_OPTS += --enable-interlace
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-interlace
+GST_PLUGINS_BAD_CONF_OPTS += --disable-interlace
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_IVFPARSE),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-ivfparse
+GST_PLUGINS_BAD_CONF_OPTS += --enable-ivfparse
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-ivfparse
+GST_PLUGINS_BAD_CONF_OPTS += --disable-ivfparse
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_JP2KDECIMATOR),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-jp2kdecimator
+GST_PLUGINS_BAD_CONF_OPTS += --enable-jp2kdecimator
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-jp2kdecimator
+GST_PLUGINS_BAD_CONF_OPTS += --disable-jp2kdecimator
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_JPEGFORMAT),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-jpegformat
+GST_PLUGINS_BAD_CONF_OPTS += --enable-jpegformat
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-jpegformat
+GST_PLUGINS_BAD_CONF_OPTS += --disable-jpegformat
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_LEGACYRESAMPLE),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-legacyresample
+GST_PLUGINS_BAD_CONF_OPTS += --enable-legacyresample
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-legacyresample
+GST_PLUGINS_BAD_CONF_OPTS += --disable-legacyresample
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_LIBRFB),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-librfb
+GST_PLUGINS_BAD_CONF_OPTS += --enable-librfb
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-librfb
+GST_PLUGINS_BAD_CONF_OPTS += --disable-librfb
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_LINSYS),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-linsys
+GST_PLUGINS_BAD_CONF_OPTS += --enable-linsys
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-linsys
+GST_PLUGINS_BAD_CONF_OPTS += --disable-linsys
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_LIVEADDER),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-liveadder
+GST_PLUGINS_BAD_CONF_OPTS += --enable-liveadder
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-liveadder
+GST_PLUGINS_BAD_CONF_OPTS += --disable-liveadder
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_MPEGDEMUX),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-mpegdemux
+GST_PLUGINS_BAD_CONF_OPTS += --enable-mpegdemux
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-mpegdemux
+GST_PLUGINS_BAD_CONF_OPTS += --disable-mpegdemux
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_MPEGPSMUX),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-mpegpsmux
+GST_PLUGINS_BAD_CONF_OPTS += --enable-mpegpsmux
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-mpegpsmux
+GST_PLUGINS_BAD_CONF_OPTS += --disable-mpegpsmux
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_MPEGTSDEMUX),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-mpegtsdemux
+GST_PLUGINS_BAD_CONF_OPTS += --enable-mpegtsdemux
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-mpegtsdemux
+GST_PLUGINS_BAD_CONF_OPTS += --disable-mpegtsdemux
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_MPEGTSMUX),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-mpegtsmux
+GST_PLUGINS_BAD_CONF_OPTS += --enable-mpegtsmux
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-mpegtsmux
+GST_PLUGINS_BAD_CONF_OPTS += --disable-mpegtsmux
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_MPEGVIDEOPARSE),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-mpegvideoparse
+GST_PLUGINS_BAD_CONF_OPTS += --enable-mpegvideoparse
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-mpegvideoparse
+GST_PLUGINS_BAD_CONF_OPTS += --disable-mpegvideoparse
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_MVE),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-mve
+GST_PLUGINS_BAD_CONF_OPTS += --enable-mve
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-mve
+GST_PLUGINS_BAD_CONF_OPTS += --disable-mve
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_MXF),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-mxf
+GST_PLUGINS_BAD_CONF_OPTS += --enable-mxf
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-mxf
+GST_PLUGINS_BAD_CONF_OPTS += --disable-mxf
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_NSF),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-nsf
+GST_PLUGINS_BAD_CONF_OPTS += --enable-nsf
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-nsf
+GST_PLUGINS_BAD_CONF_OPTS += --disable-nsf
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_NUVDEMUX),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-nuvdemux
+GST_PLUGINS_BAD_CONF_OPTS += --enable-nuvdemux
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-nuvdemux
+GST_PLUGINS_BAD_CONF_OPTS += --disable-nuvdemux
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_PATCHDETECT),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-patchdetect
+GST_PLUGINS_BAD_CONF_OPTS += --enable-patchdetect
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-patchdetect
+GST_PLUGINS_BAD_CONF_OPTS += --disable-patchdetect
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_PCAPPARSE),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-pcapparse
+GST_PLUGINS_BAD_CONF_OPTS += --enable-pcapparse
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-pcapparse
+GST_PLUGINS_BAD_CONF_OPTS += --disable-pcapparse
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_PNM),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-pnm
+GST_PLUGINS_BAD_CONF_OPTS += --enable-pnm
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-pnm
+GST_PLUGINS_BAD_CONF_OPTS += --disable-pnm
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_RAWPARSE),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-rawparse
+GST_PLUGINS_BAD_CONF_OPTS += --enable-rawparse
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-rawparse
+GST_PLUGINS_BAD_CONF_OPTS += --disable-rawparse
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_REAL),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-real
+GST_PLUGINS_BAD_CONF_OPTS += --enable-real
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-real
+GST_PLUGINS_BAD_CONF_OPTS += --disable-real
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_REMOVESILENCE),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-removesilence
+GST_PLUGINS_BAD_CONF_OPTS += --enable-removesilence
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-removesilence
+GST_PLUGINS_BAD_CONF_OPTS += --disable-removesilence
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_RTPMUX),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-rtpmux
+GST_PLUGINS_BAD_CONF_OPTS += --enable-rtpmux
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-rtpmux
+GST_PLUGINS_BAD_CONF_OPTS += --disable-rtpmux
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_RTPVP8),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-rtpvp8
+GST_PLUGINS_BAD_CONF_OPTS += --enable-rtpvp8
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-rtpvp8
+GST_PLUGINS_BAD_CONF_OPTS += --disable-rtpvp8
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_SCALETEMPO),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-scaletempo
+GST_PLUGINS_BAD_CONF_OPTS += --enable-scaletempo
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-scaletempo
+GST_PLUGINS_BAD_CONF_OPTS += --disable-scaletempo
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_SDI),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-sdi
+GST_PLUGINS_BAD_CONF_OPTS += --enable-sdi
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-sdi
+GST_PLUGINS_BAD_CONF_OPTS += --disable-sdi
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_SDP),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-sdp
+GST_PLUGINS_BAD_CONF_OPTS += --enable-sdp
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-sdp
+GST_PLUGINS_BAD_CONF_OPTS += --disable-sdp
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_SEGMENTCLIP),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-segmentclip
+GST_PLUGINS_BAD_CONF_OPTS += --enable-segmentclip
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-segmentclip
+GST_PLUGINS_BAD_CONF_OPTS += --disable-segmentclip
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_SIREN),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-siren
+GST_PLUGINS_BAD_CONF_OPTS += --enable-siren
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-siren
+GST_PLUGINS_BAD_CONF_OPTS += --disable-siren
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_SMOOTH),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-smooth
+GST_PLUGINS_BAD_CONF_OPTS += --enable-smooth
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-smooth
+GST_PLUGINS_BAD_CONF_OPTS += --disable-smooth
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_SPEED),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-speed
+GST_PLUGINS_BAD_CONF_OPTS += --enable-speed
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-speed
+GST_PLUGINS_BAD_CONF_OPTS += --disable-speed
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_SUBENC),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-subenc
+GST_PLUGINS_BAD_CONF_OPTS += --enable-subenc
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-subenc
+GST_PLUGINS_BAD_CONF_OPTS += --disable-subenc
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_STEREO),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-stereo
+GST_PLUGINS_BAD_CONF_OPTS += --enable-stereo
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-stereo
+GST_PLUGINS_BAD_CONF_OPTS += --disable-stereo
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_TTA),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-tta
+GST_PLUGINS_BAD_CONF_OPTS += --enable-tta
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-tta
+GST_PLUGINS_BAD_CONF_OPTS += --disable-tta
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_VIDEOFILTERS),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-videofilters
+GST_PLUGINS_BAD_CONF_OPTS += --enable-videofilters
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-videofilters
+GST_PLUGINS_BAD_CONF_OPTS += --disable-videofilters
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_VIDEOMAXRATE),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-videomaxrate
+GST_PLUGINS_BAD_CONF_OPTS += --enable-videomaxrate
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-videomaxrate
+GST_PLUGINS_BAD_CONF_OPTS += --disable-videomaxrate
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_VIDEOMEASURE),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-videomeasure
+GST_PLUGINS_BAD_CONF_OPTS += --enable-videomeasure
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-videomeasure
+GST_PLUGINS_BAD_CONF_OPTS += --disable-videomeasure
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_VIDEOPARSERS),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-videoparsers
+GST_PLUGINS_BAD_CONF_OPTS += --enable-videoparsers
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-videoparsers
+GST_PLUGINS_BAD_CONF_OPTS += --disable-videoparsers
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_VIDEOSIGNAL),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-videosignal
+GST_PLUGINS_BAD_CONF_OPTS += --enable-videosignal
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-videosignal
+GST_PLUGINS_BAD_CONF_OPTS += --disable-videosignal
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_VMNC),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-vmnc
+GST_PLUGINS_BAD_CONF_OPTS += --enable-vmnc
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-vmnc
+GST_PLUGINS_BAD_CONF_OPTS += --disable-vmnc
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_Y4M),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-y4m
+GST_PLUGINS_BAD_CONF_OPTS += --enable-y4m
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-y4m
+GST_PLUGINS_BAD_CONF_OPTS += --disable-y4m
endif
# plugins with deps
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_APEXSINK),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-apexsink
+GST_PLUGINS_BAD_CONF_OPTS += --enable-apexsink
GST_PLUGINS_BAD_DEPENDENCIES += openssl
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-apexsink
+GST_PLUGINS_BAD_CONF_OPTS += --disable-apexsink
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_BZ2),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-bz2
+GST_PLUGINS_BAD_CONF_OPTS += --enable-bz2
GST_PLUGINS_BAD_DEPENDENCIES += bzip2
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-bz2
+GST_PLUGINS_BAD_CONF_OPTS += --disable-bz2
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_CDAUDIO),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-cdaudio
+GST_PLUGINS_BAD_CONF_OPTS += --enable-cdaudio
GST_PLUGINS_BAD_DEPENDENCIES += libcdaudio
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-cdaudio
+GST_PLUGINS_BAD_CONF_OPTS += --disable-cdaudio
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_CURL),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-curl
+GST_PLUGINS_BAD_CONF_OPTS += --enable-curl
GST_PLUGINS_BAD_DEPENDENCIES += libcurl
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-curl
+GST_PLUGINS_BAD_CONF_OPTS += --disable-curl
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_DIRECTFB),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-directfb
+GST_PLUGINS_BAD_CONF_OPTS += --enable-directfb
GST_PLUGINS_BAD_DEPENDENCIES += directfb
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-directfb
+GST_PLUGINS_BAD_CONF_OPTS += --disable-directfb
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_DVB),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-dvb
+GST_PLUGINS_BAD_CONF_OPTS += --enable-dvb
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-dvb
+GST_PLUGINS_BAD_CONF_OPTS += --disable-dvb
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_FAAD),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-faad
+GST_PLUGINS_BAD_CONF_OPTS += --enable-faad
GST_PLUGINS_BAD_DEPENDENCIES += faad2
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-faad
+GST_PLUGINS_BAD_CONF_OPTS += --disable-faad
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_FBDEV),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-fbdev
+GST_PLUGINS_BAD_CONF_OPTS += --enable-fbdev
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-fbdev
+GST_PLUGINS_BAD_CONF_OPTS += --disable-fbdev
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_LIBMMS),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-libmms
+GST_PLUGINS_BAD_CONF_OPTS += --enable-libmms
GST_PLUGINS_BAD_DEPENDENCIES += libmms
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-libmms
+GST_PLUGINS_BAD_CONF_OPTS += --disable-libmms
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_MUSEPACK),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-musepack
+GST_PLUGINS_BAD_CONF_OPTS += --enable-musepack
GST_PLUGINS_BAD_DEPENDENCIES += musepack
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-musepack
+GST_PLUGINS_BAD_CONF_OPTS += --disable-musepack
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_NEON),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-neon
+GST_PLUGINS_BAD_CONF_OPTS += --enable-neon
GST_PLUGINS_BAD_DEPENDENCIES += neon
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-neon
+GST_PLUGINS_BAD_CONF_OPTS += --disable-neon
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_OPUS),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-opus
+GST_PLUGINS_BAD_CONF_OPTS += --enable-opus
GST_PLUGINS_BAD_DEPENDENCIES += opus
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-opus
+GST_PLUGINS_BAD_CONF_OPTS += --disable-opus
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_RSVG),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-rsvg
+GST_PLUGINS_BAD_CONF_OPTS += --enable-rsvg
GST_PLUGINS_BAD_DEPENDENCIES += librsvg
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-rsvg
+GST_PLUGINS_BAD_CONF_OPTS += --disable-rsvg
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_SDL),y)
GST_PLUGINS_BAD_CONF_ENV += ac_cv_path_SDL_CONFIG=$(STAGING_DIR)/usr/bin/sdl-config
-GST_PLUGINS_BAD_CONF_OPT += --enable-sdl
+GST_PLUGINS_BAD_CONF_OPTS += --enable-sdl
GST_PLUGINS_BAD_DEPENDENCIES += sdl
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-sdl
+GST_PLUGINS_BAD_CONF_OPTS += --disable-sdl
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_SNDFILE),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-sndfile
+GST_PLUGINS_BAD_CONF_OPTS += --enable-sndfile
GST_PLUGINS_BAD_DEPENDENCIES += libsndfile
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-sndfile
+GST_PLUGINS_BAD_CONF_OPTS += --disable-sndfile
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_VCD),y)
-GST_PLUGINS_BAD_CONF_OPT += --enable-vcd
+GST_PLUGINS_BAD_CONF_OPTS += --enable-vcd
else
-GST_PLUGINS_BAD_CONF_OPT += --disable-vcd
+GST_PLUGINS_BAD_CONF_OPTS += --disable-vcd
endif
$(eval $(autotools-package))