summaryrefslogtreecommitdiff
path: root/package/gstreamer/gst-plugins-bad
diff options
context:
space:
mode:
authorJérôme Pouiller <jezz@sysmic.org>2013-08-30 11:05:57 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2013-09-08 21:41:39 +0200
commitadf6511013b8921d6856f5dc0e053cdd27891244 (patch)
tree14f1ba25f8ae138743e3f3954b85883c636714d8 /package/gstreamer/gst-plugins-bad
parentbafa8fcc6ce90553843b5c24e68de57c40f94abe (diff)
Remove multimedia subdirectory
Unless it was a group of sub-packages, packages was never regrouped by category. multimedia/ was an exception to this rule. This patch move packages/multimedia/ sub-directories to packages/. It keeps two subdirectories for gstream 0.10 and gstreamer 1.X. Signed-off-by: Jérôme Pouiller <jezz@sysmic.org> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/gstreamer/gst-plugins-bad')
-rw-r--r--package/gstreamer/gst-plugins-bad/Config.in326
-rw-r--r--package/gstreamer/gst-plugins-bad/gst-plugins-bad-0002-fix-dfb-example.patch22
-rw-r--r--package/gstreamer/gst-plugins-bad/gst-plugins-bad-opus-jpegformat-unbreak-non-debug-build.patch78
-rw-r--r--package/gstreamer/gst-plugins-bad/gst-plugins-bad.mk581
4 files changed, 1007 insertions, 0 deletions
diff --git a/package/gstreamer/gst-plugins-bad/Config.in b/package/gstreamer/gst-plugins-bad/Config.in
new file mode 100644
index 000000000..3c5c16198
--- /dev/null
+++ b/package/gstreamer/gst-plugins-bad/Config.in
@@ -0,0 +1,326 @@
+menuconfig BR2_PACKAGE_GST_PLUGINS_BAD
+ bool "gst-plugins-bad"
+ depends on BR2_PACKAGE_GSTREAMER
+ select BR2_PACKAGE_GST_PLUGINS_BASE
+ help
+ A set of plug-ins for GStreamer that may be of poor quality or
+ lacking some features.
+
+ http://gstreamer.freedesktop.org/
+
+if BR2_PACKAGE_GST_PLUGINS_BAD
+
+comment "dependency-less plugins"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_ADPCMDEC
+ bool "adpcmdec"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_ADPCMENC
+ bool "adpcmenc"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_AIFF
+ bool "aiff"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_ASFMUX
+ bool "asfmux"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_AUTOCONVERT
+ bool "autoconvert"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_AUDIOVISUALIZERS
+ bool "audiovisualizers"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_BAYER
+ bool "bayer"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_CAMERABIN
+ bool "camerabin"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_CAMERABIN2
+ bool "camerabin2"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_CDXAPARSE
+ bool "cdxaparse"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_COLOREFFECTS
+ bool "coloreffects"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_COLORSPACE
+ bool "colorspace"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_DATAURISRC
+ bool "dataurisrc"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_DCCP
+ bool "dccp"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_DEBUGUTILS
+ bool "debugutils"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_DECKLINK
+ depends on BR2_INSTALL_LIBSTDCPP
+ bool "decklink"
+
+comment "decklink requires a toolchain with C++ support enabled"
+ depends on !BR2_INSTALL_LIBSTDCPP
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_DTMF
+ bool "dtmf"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_DVBSUBOVERLAY
+ bool "dvdsuboverlay"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_DVDSPU
+ bool "dvdspu"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_FACEOVERLAY
+ bool "faceoverlay"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_FESTIVAL
+ bool "festival"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_FIELDANALYSIS
+ bool "fieldanalysis"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_FREEVERB
+ bool "freeverb"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_FREEZE
+ bool "freeze"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_FREI0R
+ bool "frei0r"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_GAUDIEFFECTS
+ bool "gaudieffects"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_GEOMETRICTRANSFORM
+ bool "geometrictransform"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_GSETTINGS
+ bool "gsettings"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_H264PARSE
+ bool "h264parse"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_HDVPARSE
+ bool "hdvparse"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_HLS
+ bool "hls"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_ID3TAG
+ bool "id3tag"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_INTER
+ bool "inter"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_INTERLACE
+ bool "interlace"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_IVFPARSE
+ bool "ivfparse"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_JP2KDECIMATOR
+ bool "jp2kdecimator"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_JPEGFORMAT
+ bool "jpegformat"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_LEGACYRESAMPLE
+ bool "legacyresample"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_LIBRFB
+ bool "librfb"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_LINSYS
+ bool "linsys"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_LIVEADDER
+ bool "liveadder"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_MPEGDEMUX
+ bool "mpegdemux"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_MPEGPSMUX
+ bool "mpegpsmux"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_MPEGTSDEMUX
+ bool "mpegtsdemux"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_MPEGTSMUX
+ bool "mpegtsmux"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_MPEGVIDEOPARSE
+ bool "mpegvideoparse"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_MVE
+ bool "mve"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_MXF
+ bool "mxf"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_NSF
+ bool "nsf"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_NUVDEMUX
+ bool "nuvdemux"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_PATCHDETECT
+ bool "patchdetect"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_PCAPPARSE
+ bool "pcapparse"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_PNM
+ bool "pnm"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_RAWPARSE
+ bool "rawparse"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_REAL
+ bool "real"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_REMOVESILENCE
+ bool "removesilence"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_RTPMUX
+ bool "rtpmux"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_RTPVP8
+ bool "rtpvp8"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_SCALETEMPO
+ bool "scaletempo"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_SDI
+ bool "sdi"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_SDP
+ bool "sdp"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_SEGMENTCLIP
+ bool "segmentclip"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_SIREN
+ bool "siren"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_SMOOTH
+ bool "smooth"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_SPEED
+ bool "speed"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_STEREO
+ bool "stereo"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_SUBENC
+ bool "subenc"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_TTA
+ bool "tta"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_VIDEOFILTERS
+ bool "videofilters"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_VIDEOMAXRATE
+ bool "videomaxrate"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_VIDEOMEASURE
+ bool "videomeasure"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_VIDEOPARSERS
+ bool "videoparsers"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_VIDEOSIGNAL
+ bool "videosignal"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_VMNC
+ bool "vmnc"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_Y4M
+ bool "y4m"
+
+comment "plugins with external dependencies (there may be more available)"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_APEXSINK
+ bool "apexsink"
+ select BR2_PACKAGE_OPENSSL
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_BZ2
+ bool "bz2"
+ select BR2_PACKAGE_BZIP2
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_CDAUDIO
+ bool "cdaudio"
+ select BR2_PACKAGE_LIBCDAUDIO
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_CURL
+ bool "curl"
+ select BR2_PACKAGE_LIBCURL
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_DIRECTFB
+ bool "directfb"
+ select BR2_PACKAGE_DIRECTFB
+ depends on BR2_TOOLCHAIN_HAS_THREADS
+ depends on BR2_INSTALL_LIBSTDCPP
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_DVB
+ bool "dvb"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_FBDEV
+ bool "fbdev"
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_FAAD
+ bool "faad"
+ select BR2_PACKAGE_FAAD2
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_LIBMMS
+ bool "libmms"
+ depends on BR2_USE_WCHAR # libmms -> libglib2
+ depends on BR2_TOOLCHAIN_HAS_THREADS # libmms -> libglib2
+ select BR2_PACKAGE_LIBMMS
+
+comment "libmms requires a toolchain with WCHAR and threading support"
+ depends on !BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREADS
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_MUSEPACK
+ bool "musepack"
+ select BR2_PACKAGE_MUSEPACK
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_NEON
+ bool "neon"
+ select BR2_PACKAGE_NEON
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_OPUS
+ bool "opus"
+ select BR2_PACKAGE_OPUS
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_RSVG
+ bool "rsvg"
+ depends on BR2_INSTALL_LIBSTDCPP
+ depends on BR2_USE_WCHAR # librsvg -> libglib2
+ depends on BR2_TOOLCHAIN_HAS_THREADS # librsvg -> libglib2
+ select BR2_PACKAGE_LIBRSVG
+
+comment "rsvg plugin requires a toolchain with C++, WCHAR, and threading support"
+ depends on !BR2_INSTALL_LIBSTDCPP || !BR2_USE_WCHAR || \
+ !BR2_TOOLCHAIN_HAS_THREADS
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_SDL
+ bool "sdl"
+ select BR2_PACKAGE_SDL
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_SNDFILE
+ bool "sndfile"
+ select BR2_PACKAGE_LIBSNDFILE
+ depends on BR2_LARGEFILE
+
+comment "gst-plugins-bad-plugin-sndfile requires a toolchain with LARGEFILE support"
+ depends on !BR2_LARGEFILE
+
+config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_VCD
+ bool "vcd"
+
+endif
+
diff --git a/package/gstreamer/gst-plugins-bad/gst-plugins-bad-0002-fix-dfb-example.patch b/package/gstreamer/gst-plugins-bad/gst-plugins-bad-0002-fix-dfb-example.patch
new file mode 100644
index 000000000..b2057484c
--- /dev/null
+++ b/package/gstreamer/gst-plugins-bad/gst-plugins-bad-0002-fix-dfb-example.patch
@@ -0,0 +1,22 @@
+Fix dfb-example
+
+Order of inclusion gives a strange effect on the definition of
+gst_debug_log. Swapping the include statements solve it.
+
+Not upstreamed since there will be no more updates to this version
+of gst-plugins-bad.
+
+Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
+---
+diff -rup gst-plugins-bad-0.10.23/ext/directfb/dfb-example.c gst-plugins-bad-0.10.23.fixed/ext/directfb/dfb-example.c
+--- gst-plugins-bad-0.10.23/ext/directfb/dfb-example.c 2011-12-11 19:49:11.000000000 +0100
++++ gst-plugins-bad-0.10.23.fixed/ext/directfb/dfb-example.c 2013-05-13 00:32:00.507469138 +0200
+@@ -1,7 +1,7 @@
+
+-#include <directfb.h>
+ #include <stdio.h>
+ #include <gst/gst.h>
++#include <directfb.h>
+
+ static IDirectFB *dfb = NULL;
+ static IDirectFBSurface *primary = NULL;
diff --git a/package/gstreamer/gst-plugins-bad/gst-plugins-bad-opus-jpegformat-unbreak-non-debug-build.patch b/package/gstreamer/gst-plugins-bad/gst-plugins-bad-opus-jpegformat-unbreak-non-debug-build.patch
new file mode 100644
index 000000000..2c98c3e10
--- /dev/null
+++ b/package/gstreamer/gst-plugins-bad/gst-plugins-bad-opus-jpegformat-unbreak-non-debug-build.patch
@@ -0,0 +1,78 @@
+From 1725e702a3622cb45c8142622dd419fa0c410ac9 Mon Sep 17 00:00:00 2001
+From: Peter Korsgaard <jacmet@sunsite.dk>
+Date: Wed, 12 Sep 2012 09:10:35 +0200
+Subject: [PATCH] gst-plugins-bad: opus + jpegformat: unbreak non-debug build
+
+opus + jpegformat plugin builds fail when gstreamer is configured with
+--disable-gst-debug as they are checking the GST_DISABLE_DEBUG symbol
+instead of GST_DISABLE_GST_DEBUG.
+
+Submitted upstream as https://bugzilla.gnome.org/show_bug.cgi?id=683850
+
+Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
+---
+ ext/opus/gstopusdec.c | 2 +-
+ ext/opus/gstopusenc.c | 4 ++--
+ gst/jpegformat/gstjpegparse.c | 4 ++--
+ 3 files changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/ext/opus/gstopusdec.c b/ext/opus/gstopusdec.c
+index 0e2805c..ab7221d 100644
+--- a/ext/opus/gstopusdec.c
++++ b/ext/opus/gstopusdec.c
+@@ -357,7 +357,7 @@ opus_dec_chain_parse_data (GstOpusDec * dec, GstBuffer * buffer)
+
+ GST_DEBUG_OBJECT (dec, "Creating decoder with %d channels, %d Hz",
+ dec->n_channels, dec->sample_rate);
+-#ifndef GST_DISABLE_DEBUG
++#ifndef GST_DISABLE_GST_DEBUG
+ gst_opus_common_log_channel_mapping_table (GST_ELEMENT (dec), opusdec_debug,
+ "Mapping table", dec->n_channels, dec->channel_mapping);
+ #endif
+diff --git a/ext/opus/gstopusenc.c b/ext/opus/gstopusenc.c
+index 240a2cb..d991795 100644
+--- a/ext/opus/gstopusenc.c
++++ b/ext/opus/gstopusenc.c
+@@ -589,7 +589,7 @@ gst_opus_enc_setup_channel_mappings (GstOpusEnc * enc,
+ }
+ }
+
+-#ifndef GST_DISABLE_DEBUG
++#ifndef GST_DISABLE_GST_DEBUG
+ GST_INFO_OBJECT (enc,
+ "Mapping tables built: %d channels, %d stereo streams", enc->n_channels,
+ enc->n_stereo_streams);
+@@ -654,7 +654,7 @@ gst_opus_enc_setup (GstOpusEnc * enc)
+ {
+ int error = OPUS_OK;
+
+-#ifndef GST_DISABLE_DEBUG
++#ifndef GST_DISABLE_GST_DEBUG
+ GST_DEBUG_OBJECT (enc,
+ "setup: %d Hz, %d channels, %d stereo streams, family %d",
+ enc->sample_rate, enc->n_channels, enc->n_stereo_streams,
+diff --git a/gst/jpegformat/gstjpegparse.c b/gst/jpegformat/gstjpegparse.c
+index f984a52..b4af9ed 100644
+--- a/gst/jpegformat/gstjpegparse.c
++++ b/gst/jpegformat/gstjpegparse.c
+@@ -545,7 +545,7 @@ gst_jpeg_parse_skip_marker (GstJpegParse * parse,
+ if (!gst_byte_reader_get_uint16_be (reader, &size))
+ return FALSE;
+
+-#ifndef GST_DISABLE_DEBUG
++#ifndef GST_DISABLE_GST_DEBUG
+ /* We'd pry the id of the skipped application segment */
+ if (marker >= APP0 && marker <= APP15) {
+ const gchar *id_str = NULL;
+@@ -561,7 +561,7 @@ gst_jpeg_parse_skip_marker (GstJpegParse * parse,
+ #else
+ GST_DEBUG_OBJECT (parse, "unhandled marker %x skiping %u bytes", marker,
+ size);
+-#endif // GST_DISABLE_DEBUG
++#endif // GST_DISABLE_GST_DEBUG
+
+ if (!gst_byte_reader_skip (reader, size - 2))
+ return FALSE;
+--
+1.7.10
+
diff --git a/package/gstreamer/gst-plugins-bad/gst-plugins-bad.mk b/package/gstreamer/gst-plugins-bad/gst-plugins-bad.mk
new file mode 100644
index 000000000..df90cf9b5
--- /dev/null
+++ b/package/gstreamer/gst-plugins-bad/gst-plugins-bad.mk
@@ -0,0 +1,581 @@
+################################################################################
+#
+# gst-plugins-bad
+#
+################################################################################
+
+GST_PLUGINS_BAD_VERSION = 0.10.23
+GST_PLUGINS_BAD_SOURCE = gst-plugins-bad-$(GST_PLUGINS_BAD_VERSION).tar.bz2
+GST_PLUGINS_BAD_SITE = http://gstreamer.freedesktop.org/src/gst-plugins-bad
+
+GST_PLUGINS_BAD_CONF_OPT = \
+ --disable-examples
+
+GST_PLUGINS_BAD_DEPENDENCIES = gst-plugins-base gstreamer
+
+ifeq ($(BR2_PACKAGE_ORC),y)
+GST_PLUGINS_BAD_DEPENDENCIES += orc
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_ADPCMDEC),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-adpcmdec
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-adpcmdec
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_ADPCMENC),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-adpcmenc
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-adpcmenc
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_AIFF),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-aiff
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-aiff
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_ASFMUX),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-asfmux
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-asfmux
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_AUDIOVISUALIZERS),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-audiovisualizers
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-audiovisualizers
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_AUTOCONVERT),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-autoconvert
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-autoconvert
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_BAYER),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-bayer
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-bayer
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_CAMERABIN),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-camerabin
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-camerabin
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_CAMERABIN2),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-camerabin2
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-camerabin2
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_CDXAPARSE),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-cdxaparse
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-cdxaparse
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_COLOREFFECTS),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-coloreffects
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-coloreffects
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_COLORSPACE),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-colorspace
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-colorspace
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_DATAURISRC),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-dataurisrc
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-dataurisrc
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_DCCP),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-dccp
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-dccp
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_DEBUGUTILS),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-debugutils
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-debugutils
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_DECKLINK),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-decklink
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-decklink
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_DTMF),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-dtmf
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-dtmf
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_DVBSUBOVERLAY),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-dvbsuboverlay
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-dvbsuboverlay
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_DVDSPU),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-dvdspu
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-dvdspu
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_FACEOVERLAY),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-faceoverlay
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-faceoverlay
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_FESTIVAL),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-festival
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-festival
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_FIELDANALYSIS),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-fieldanalysis
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-fieldanalysis
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_FREEZE),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-freeze
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-freeze
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_FREEVERB),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-freeverb
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-freeverb
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_FREI0R),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-frei0r
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-frei0r
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_GAUDIEFFECTS),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-gaudieffects
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-gaudieffects
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_GEOMETRICTRANSFORM),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-geometrictransform
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-geometrictransform
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_GSETTINGS),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-gsettings
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-gsettings
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_H264PARSE),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-h264parse
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-h264parse
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_HDVPARSE),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-hdvparse
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-hdvparse
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_HLS),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-hls
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-hls
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_ID3TAG),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-id3tag
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-id3tag
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_INTER),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-inter
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-inter
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_INTERLACE),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-interlace
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-interlace
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_IVFPARSE),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-ivfparse
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-ivfparse
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_JP2KDECIMATOR),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-jp2kdecimator
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-jp2kdecimator
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_JPEGFORMAT),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-jpegformat
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-jpegformat
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_LEGACYRESAMPLE),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-legacyresample
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-legacyresample
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_LIBRFB),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-librfb
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-librfb
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_LINSYS),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-linsys
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-linsys
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_LIVEADDER),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-liveadder
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-liveadder
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_MPEGDEMUX),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-mpegdemux
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-mpegdemux
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_MPEGPSMUX),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-mpegpsmux
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-mpegpsmux
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_MPEGTSDEMUX),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-mpegtsdemux
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-mpegtsdemux
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_MPEGTSMUX),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-mpegtsmux
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-mpegtsmux
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_MPEGVIDEOPARSE),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-mpegvideoparse
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-mpegvideoparse
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_MVE),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-mve
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-mve
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_MXF),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-mxf
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-mxf
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_NSF),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-nsf
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-nsf
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_NUVDEMUX),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-nuvdemux
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-nuvdemux
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_PATCHDETECT),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-patchdetect
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-patchdetect
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_PCAPPARSE),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-pcapparse
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-pcapparse
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_PNM),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-pnm
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-pnm
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_RAWPARSE),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-rawparse
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-rawparse
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_REAL),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-real
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-real
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_REMOVESILENCE),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-removesilence
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-removesilence
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_RTPMUX),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-rtpmux
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-rtpmux
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_RTPVP8),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-rtpvp8
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-rtpvp8
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_SCALETEMPO),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-scaletempo
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-scaletempo
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_SDI),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-sdi
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-sdi
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_SDP),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-sdp
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-sdp
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_SEGMENTCLIP),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-segmentclip
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-segmentclip
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_SIREN),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-siren
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-siren
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_SMOOTH),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-smooth
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-smooth
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_SPEED),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-speed
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-speed
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_SUBENC),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-subenc
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-subenc
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_STEREO),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-stereo
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-stereo
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_TTA),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-tta
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-tta
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_VIDEOFILTERS),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-videofilters
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-videofilters
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_VIDEOMAXRATE),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-videomaxrate
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-videomaxrate
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_VIDEOMEASURE),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-videomeasure
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-videomeasure
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_VIDEOPARSERS),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-videoparsers
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-videoparsers
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_VIDEOSIGNAL),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-videosignal
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-videosignal
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_VMNC),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-vmnc
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-vmnc
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_Y4M),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-y4m
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-y4m
+endif
+
+# plugins with deps
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_APEXSINK),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-apexsink
+GST_PLUGINS_BAD_DEPENDENCIES += openssl
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-apexsink
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_BZ2),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-bz2
+GST_PLUGINS_BAD_DEPENDENCIES += bzip2
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-bz2
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_CDAUDIO),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-cdaudio
+GST_PLUGINS_BAD_DEPENDENCIES += libcdaudio
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-cdaudio
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_CURL),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-curl
+GST_PLUGINS_BAD_DEPENDENCIES += libcurl
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-curl
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_DIRECTFB),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-directfb
+GST_PLUGINS_BAD_DEPENDENCIES += directfb
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-directfb
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_DVB),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-dvb
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-dvb
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_FAAD),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-faad
+GST_PLUGINS_BAD_DEPENDENCIES += faad2
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-faad
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_FBDEV),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-fbdev
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-fbdev
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_LIBMMS),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-libmms
+GST_PLUGINS_BAD_DEPENDENCIES += libmms
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-libmms
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_MUSEPACK),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-musepack
+GST_PLUGINS_BAD_DEPENDENCIES += musepack
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-musepack
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_NEON),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-neon
+GST_PLUGINS_BAD_DEPENDENCIES += neon
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-neon
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_OPUS),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-opus
+GST_PLUGINS_BAD_DEPENDENCIES += opus
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-opus
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_RSVG),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-rsvg
+GST_PLUGINS_BAD_DEPENDENCIES += librsvg
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-rsvg
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_SDL),y)
+GST_PLUGINS_BAD_CONF_ENV += ac_cv_path_SDL_CONFIG=$(STAGING_DIR)/usr/bin/sdl-config
+GST_PLUGINS_BAD_CONF_OPT += --enable-sdl
+GST_PLUGINS_BAD_DEPENDENCIES += sdl
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-sdl
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_SNDFILE),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-sndfile
+GST_PLUGINS_BAD_DEPENDENCIES += libsndfile
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-sndfile
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_VCD),y)
+GST_PLUGINS_BAD_CONF_OPT += --enable-vcd
+else
+GST_PLUGINS_BAD_CONF_OPT += --disable-vcd
+endif
+
+$(eval $(autotools-package))