summaryrefslogtreecommitdiff
path: root/package/gstreamer/gst-plugins-base
diff options
context:
space:
mode:
authorThomas De Schampheleire <patrickdepinguin@gmail.com>2014-09-27 21:32:44 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-10-04 18:54:16 +0200
commitaaffd209fae91a733fe0becb72268f87bf4ea369 (patch)
tree40569895ef8a09c605060e2164d86567a12f9889 /package/gstreamer/gst-plugins-base
parent1d2574ac6f6d30044ee138b6235c50a6a3998d8a (diff)
packages: rename FOO_CONF_OPT into FOO_CONF_OPTS
To be consistent with the recent change of FOO_MAKE_OPT into FOO_MAKE_OPTS, make the same change for FOO_CONF_OPT. Sed command used: find * -type f | xargs sed -i 's#_CONF_OPT\>#&S#g' Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/gstreamer/gst-plugins-base')
-rw-r--r--package/gstreamer/gst-plugins-base/gst-plugins-base.mk98
1 files changed, 49 insertions, 49 deletions
diff --git a/package/gstreamer/gst-plugins-base/gst-plugins-base.mk b/package/gstreamer/gst-plugins-base/gst-plugins-base.mk
index 6c7233ba4..7e461df74 100644
--- a/package/gstreamer/gst-plugins-base/gst-plugins-base.mk
+++ b/package/gstreamer/gst-plugins-base/gst-plugins-base.mk
@@ -16,7 +16,7 @@ GST_PLUGINS_BASE_CONF_ENV =
FT2_CONFIG=/bin/false \
ac_cv_header_stdint_t="stdint.h"
-GST_PLUGINS_BASE_CONF_OPT = \
+GST_PLUGINS_BASE_CONF_OPTS = \
--disable-examples \
--disable-oggtest \
--disable-vorbistest \
@@ -26,12 +26,12 @@ GST_PLUGINS_BASE_DEPENDENCIES = gstreamer
ifeq ($(BR2_PACKAGE_XORG7),y)
GST_PLUGINS_BASE_DEPENDENCIES += xlib_libX11 xlib_libXext xlib_libXv
-GST_PLUGINS_BASE_CONF_OPT += \
+GST_PLUGINS_BASE_CONF_OPTS += \
--enable-x \
--enable-xshm \
--enable-xvideo
else
-GST_PLUGINS_BASE_CONF_OPT += \
+GST_PLUGINS_BASE_CONF_OPTS += \
--disable-x \
--disable-xshm \
--disable-xvideo
@@ -44,150 +44,150 @@ endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_ALSA),y)
GST_PLUGINS_BASE_DEPENDENCIES += alsa-lib
else
-GST_PLUGINS_BASE_CONF_OPT += --disable-alsa
+GST_PLUGINS_BASE_CONF_OPTS += --disable-alsa
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_ADDER),y)
-GST_PLUGINS_BASE_CONF_OPT += --enable-adder
+GST_PLUGINS_BASE_CONF_OPTS += --enable-adder
else
-GST_PLUGINS_BASE_CONF_OPT += --disable-adder
+GST_PLUGINS_BASE_CONF_OPTS += --disable-adder
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_APP),y)
-GST_PLUGINS_BASE_CONF_OPT += --enable-app
+GST_PLUGINS_BASE_CONF_OPTS += --enable-app
else
-GST_PLUGINS_BASE_CONF_OPT += --disable-app
+GST_PLUGINS_BASE_CONF_OPTS += --disable-app
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_AUDIOCONVERT),y)
-GST_PLUGINS_BASE_CONF_OPT += --enable-audioconvert
+GST_PLUGINS_BASE_CONF_OPTS += --enable-audioconvert
else
-GST_PLUGINS_BASE_CONF_OPT += --disable-audioconvert
+GST_PLUGINS_BASE_CONF_OPTS += --disable-audioconvert
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_AUDIORATE),y)
-GST_PLUGINS_BASE_CONF_OPT += --enable-audiorate
+GST_PLUGINS_BASE_CONF_OPTS += --enable-audiorate
else
-GST_PLUGINS_BASE_CONF_OPT += --disable-audiorate
+GST_PLUGINS_BASE_CONF_OPTS += --disable-audiorate
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_AUDIORESAMPLE),y)
-GST_PLUGINS_BASE_CONF_OPT += --enable-audioresample
+GST_PLUGINS_BASE_CONF_OPTS += --enable-audioresample
else
-GST_PLUGINS_BASE_CONF_OPT += --disable-audioresample
+GST_PLUGINS_BASE_CONF_OPTS += --disable-audioresample
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_AUDIOTESTSRC),y)
-GST_PLUGINS_BASE_CONF_OPT += --enable-audiotestsrc
+GST_PLUGINS_BASE_CONF_OPTS += --enable-audiotestsrc
else
-GST_PLUGINS_BASE_CONF_OPT += --disable-audiotestsrc
+GST_PLUGINS_BASE_CONF_OPTS += --disable-audiotestsrc
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_ENCODING),y)
-GST_PLUGINS_BASE_CONF_OPT += --enable-encoding
+GST_PLUGINS_BASE_CONF_OPTS += --enable-encoding
else
-GST_PLUGINS_BASE_CONF_OPT += --disable-encoding
+GST_PLUGINS_BASE_CONF_OPTS += --disable-encoding
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_FFMPEGCOLORSPACE),y)
-GST_PLUGINS_BASE_CONF_OPT += --enable-ffmpegcolorspace
+GST_PLUGINS_BASE_CONF_OPTS += --enable-ffmpegcolorspace
else
-GST_PLUGINS_BASE_CONF_OPT += --disable-ffmpegcolorspace
+GST_PLUGINS_BASE_CONF_OPTS += --disable-ffmpegcolorspace
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_GDP),y)
-GST_PLUGINS_BASE_CONF_OPT += --enable-gdp
+GST_PLUGINS_BASE_CONF_OPTS += --enable-gdp
else
-GST_PLUGINS_BASE_CONF_OPT += --disable-gdp
+GST_PLUGINS_BASE_CONF_OPTS += --disable-gdp
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_PLAYBACK),y)
-GST_PLUGINS_BASE_CONF_OPT += --enable-playback
+GST_PLUGINS_BASE_CONF_OPTS += --enable-playback
else
-GST_PLUGINS_BASE_CONF_OPT += --disable-playback
+GST_PLUGINS_BASE_CONF_OPTS += --disable-playback
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_SUBPARSE),y)
-GST_PLUGINS_BASE_CONF_OPT += --enable-subparse
+GST_PLUGINS_BASE_CONF_OPTS += --enable-subparse
else
-GST_PLUGINS_BASE_CONF_OPT += --disable-subparse
+GST_PLUGINS_BASE_CONF_OPTS += --disable-subparse
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_TCP),y)
-GST_PLUGINS_BASE_CONF_OPT += --enable-tcp
+GST_PLUGINS_BASE_CONF_OPTS += --enable-tcp
else
-GST_PLUGINS_BASE_CONF_OPT += --disable-tcp
+GST_PLUGINS_BASE_CONF_OPTS += --disable-tcp
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_TYPEFIND),y)
-GST_PLUGINS_BASE_CONF_OPT += --enable-typefind
+GST_PLUGINS_BASE_CONF_OPTS += --enable-typefind
else
-GST_PLUGINS_BASE_CONF_OPT += --disable-typefind
+GST_PLUGINS_BASE_CONF_OPTS += --disable-typefind
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_VIDEOTESTSRC),y)
-GST_PLUGINS_BASE_CONF_OPT += --enable-videotestsrc
+GST_PLUGINS_BASE_CONF_OPTS += --enable-videotestsrc
else
-GST_PLUGINS_BASE_CONF_OPT += --disable-videotestsrc
+GST_PLUGINS_BASE_CONF_OPTS += --disable-videotestsrc
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_VIDEORATE),y)
-GST_PLUGINS_BASE_CONF_OPT += --enable-videorate
+GST_PLUGINS_BASE_CONF_OPTS += --enable-videorate
else
-GST_PLUGINS_BASE_CONF_OPT += --disable-videorate
+GST_PLUGINS_BASE_CONF_OPTS += --disable-videorate
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_VIDEOSCALE),y)
-GST_PLUGINS_BASE_CONF_OPT += --enable-videoscale
+GST_PLUGINS_BASE_CONF_OPTS += --enable-videoscale
else
-GST_PLUGINS_BASE_CONF_OPT += --disable-videoscale
+GST_PLUGINS_BASE_CONF_OPTS += --disable-videoscale
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_VOLUME),y)
-GST_PLUGINS_BASE_CONF_OPT += --enable-volume
+GST_PLUGINS_BASE_CONF_OPTS += --enable-volume
else
-GST_PLUGINS_BASE_CONF_OPT += --disable-volume
+GST_PLUGINS_BASE_CONF_OPTS += --disable-volume
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_OGG),y)
-GST_PLUGINS_BASE_CONF_OPT += --enable-ogg
+GST_PLUGINS_BASE_CONF_OPTS += --enable-ogg
GST_PLUGINS_BASE_DEPENDENCIES += libogg
else
-GST_PLUGINS_BASE_CONF_OPT += --disable-ogg
+GST_PLUGINS_BASE_CONF_OPTS += --disable-ogg
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_PANGO),y)
-GST_PLUGINS_BASE_CONF_OPT += --enable-pango
+GST_PLUGINS_BASE_CONF_OPTS += --enable-pango
GST_PLUGINS_BASE_DEPENDENCIES += pango
else
-GST_PLUGINS_BASE_CONF_OPT += --disable-pango
+GST_PLUGINS_BASE_CONF_OPTS += --disable-pango
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_THEORA),y)
-GST_PLUGINS_BASE_CONF_OPT += --enable-theora
+GST_PLUGINS_BASE_CONF_OPTS += --enable-theora
GST_PLUGINS_BASE_DEPENDENCIES += libtheora
else
-GST_PLUGINS_BASE_CONF_OPT += --disable-theora
+GST_PLUGINS_BASE_CONF_OPTS += --disable-theora
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_TREMOR),y)
-GST_PLUGINS_BASE_CONF_OPT += --enable-ivorbis
+GST_PLUGINS_BASE_CONF_OPTS += --enable-ivorbis
GST_PLUGINS_BASE_DEPENDENCIES += tremor
else
-GST_PLUGINS_BASE_CONF_OPT += --disable-ivorbis
+GST_PLUGINS_BASE_CONF_OPTS += --disable-ivorbis
endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_VORBIS),y)
-GST_PLUGINS_BASE_CONF_OPT += --enable-vorbis
+GST_PLUGINS_BASE_CONF_OPTS += --enable-vorbis
GST_PLUGINS_BASE_DEPENDENCIES += libvorbis
else
-GST_PLUGINS_BASE_CONF_OPT += --disable-vorbis
+GST_PLUGINS_BASE_CONF_OPTS += --disable-vorbis
endif
ifeq ($(BR2_PACKAGE_ZLIB),y)
GST_PLUGINS_BASE_DEPENDENCIES += zlib
else
-GST_PLUGINS_BASE_CONF_OPT += --disable-zlib
+GST_PLUGINS_BASE_CONF_OPTS += --disable-zlib
endif
$(eval $(autotools-package))