summaryrefslogtreecommitdiff
path: root/package/gstreamer/gst-plugins-good
diff options
context:
space:
mode:
authorJérôme Pouiller <jezz@sysmic.org>2013-08-30 11:05:57 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2013-09-08 21:41:39 +0200
commitadf6511013b8921d6856f5dc0e053cdd27891244 (patch)
tree14f1ba25f8ae138743e3f3954b85883c636714d8 /package/gstreamer/gst-plugins-good
parentbafa8fcc6ce90553843b5c24e68de57c40f94abe (diff)
Remove multimedia subdirectory
Unless it was a group of sub-packages, packages was never regrouped by category. multimedia/ was an exception to this rule. This patch move packages/multimedia/ sub-directories to packages/. It keeps two subdirectories for gstream 0.10 and gstreamer 1.X. Signed-off-by: Jérôme Pouiller <jezz@sysmic.org> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/gstreamer/gst-plugins-good')
-rw-r--r--package/gstreamer/gst-plugins-good/Config.in227
-rw-r--r--package/gstreamer/gst-plugins-good/gst-plugins-good-linux36.patch37
-rw-r--r--package/gstreamer/gst-plugins-good/gst-plugins-good-v4l2-fix-compilation-against-newer-kernel-headers.patch30
-rw-r--r--package/gstreamer/gst-plugins-good/gst-plugins-good.mk393
4 files changed, 687 insertions, 0 deletions
diff --git a/package/gstreamer/gst-plugins-good/Config.in b/package/gstreamer/gst-plugins-good/Config.in
new file mode 100644
index 000000000..c604a41a0
--- /dev/null
+++ b/package/gstreamer/gst-plugins-good/Config.in
@@ -0,0 +1,227 @@
+menuconfig BR2_PACKAGE_GST_PLUGINS_GOOD
+ bool "gst-plugins-good"
+ depends on BR2_PACKAGE_GSTREAMER
+ select BR2_PACKAGE_GST_PLUGINS_BASE
+ help
+ A set of well-supported plug-ins for GStreamer under the preferred
+ license.
+
+ http://gstreamer.freedesktop.org/
+
+if BR2_PACKAGE_GST_PLUGINS_GOOD
+
+config BR2_PACKAGE_GST_PLUGINS_GOOD_JPEG
+ bool "jpeg (JPEG support)"
+ select BR2_PACKAGE_JPEG
+
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PNG
+ bool "png (PNG support)"
+ select BR2_PACKAGE_LIBPNG
+
+config BR2_PACKAGE_GST_PLUGINS_GOOD_BZ2
+ bool "bz2 support"
+ depends on BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_MATROSKA
+ select BR2_PACKAGE_BZIP2
+ help
+ Enable bz2 support for the following plugins:
+ matroska
+
+config BR2_PACKAGE_GST_PLUGINS_GOOD_ZLIB
+ bool "zlib support"
+ depends on BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_QTDEMUX || BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_ID3DEMUX || BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_MATROSKA
+ select BR2_PACKAGE_ZLIB
+ help
+ Enable zlib support for the following plugins:
+ id3demux, qtdemux, matroska
+
+comment "dependency-less plugins"
+
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_ALPHA
+ bool "alpha"
+
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_APETAG
+ bool "apetag"
+
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_AUDIOFX
+ bool "audiofx"
+
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_AUDIOPARSERS
+ bool "audioparsers"
+
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_AUPARSE
+ bool "auparse"
+
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_AUTODETECT
+ bool "autodetect"
+
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_AVI
+ bool "avi (*.avi video)"
+ default y
+
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_CUTTER
+ bool "cutter"
+
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_DEBUGUTILS
+ bool "debugutils"
+
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_DEINTERLACE
+ bool "deinterlace"
+
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_EFFECTV
+ bool "effectv"
+
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_EQUALIZER
+ bool "equalizer"
+
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_FLV
+ bool "flv"
+
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_FLX
+ bool "flx"
+
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_GOOM
+ bool "goom"
+
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_GOOM2K1
+ bool "goom2k1"
+
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_ID3DEMUX
+ bool "id3demux (*.mp3 audio)"
+
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_ICYDEMUX
+ bool "icydemux"
+
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_IMAGEFREEZE
+ bool "imagefreeze"
+
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_INTERLEAVE
+ bool "interleave"
+
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_ISOMP4
+ bool "isomp4"
+
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_LAW
+ bool "law"
+
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_LEVEL
+ bool "level"
+
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_MATROSKA
+ bool "matroska"
+
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_MONOSCOPE
+ bool "monoscope"
+
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_MULTIFILE
+ bool "multifile"
+
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_MULTIPART
+ bool "multipart"
+
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_REPLAYGAIN
+ bool "replaygain"
+
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_RTP
+ bool "rtp"
+
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_RTPMANAGER
+ bool "rtpmanager"
+
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_RTSP
+ bool "rtsp"
+
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_SHAPEWIPE
+ bool "shapewipe"
+
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_SMPTE
+ bool "smpte"
+
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_SPECTRUM
+ bool "spectrum"
+
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_UDP
+ depends on BR2_INET_IPV6
+ bool "udp"
+
+comment "udp requires a toolchain with IPv6 support"
+ depends on !BR2_INET_IPV6
+
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_VIDEOBOX
+ bool "videobox"
+
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_VIDEOCROP
+ bool "videocrop"
+
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_VIDEOFILTER
+ bool "videofilter"
+
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_VIDEOMIXER
+ bool "videomixer"
+
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_WAVENC
+ bool "wavenc"
+
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_WAVPARSE
+ bool "wavparse (*.wav audio)"
+ default y
+
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_Y4M
+ bool "y4m"
+
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_V4L2
+ bool "v4l2"
+
+comment "plugins with external dependencies"
+
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_ANNODEX
+ bool "annodex (XML Library)"
+ select BR2_PACKAGE_LIBXML2
+
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_CAIRO
+ bool "cairo"
+ select BR2_PACKAGE_CAIRO
+ select BR2_PACKAGE_CAIRO_PNG
+
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_FLAC
+ bool "flac (libFLAC)"
+ select BR2_PACKAGE_FLAC
+
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_GDKPIXBUF
+ bool "gdkpixbuf"
+ depends on BR2_USE_WCHAR # gdk-pixbuf -> libglib2
+ depends on BR2_TOOLCHAIN_HAS_THREADS # gdk-pixbuf -> libglib2
+ select BR2_PACKAGE_GDK_PIXBUF
+
+comment "gdkpixbuf requires a toolchain with WCHAR and threading support"
+ depends on !BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREADS
+
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_OSS
+ bool "ossaudio (OSS audio)"
+
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_OSS4
+ bool "oss4 (Open Sound System 4)"
+
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_PULSE
+ depends on BR2_TOOLCHAIN_HAS_THREADS # pulseaudio
+ depends on BR2_LARGEFILE # pulseaudio -> libsndfile
+ select BR2_PACKAGE_PULSEAUDIO
+ bool "pulseaudio"
+
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_SOUPHTTPSRC
+ bool "souphttpsrc (http client)"
+ depends on BR2_USE_WCHAR # libsoup -> glib2
+ depends on BR2_TOOLCHAIN_HAS_THREADS # libsoup -> glib2
+ select BR2_PACKAGE_LIBSOUP
+
+comment "souphttpsrc requires a toolchain with WCHAR and threading support"
+ depends on !BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREAD
+
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_SPEEX
+ bool "speex"
+ select BR2_PACKAGE_SPEEX
+
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_WAVPACK
+ bool "wavpack (*.wv audio)"
+ select BR2_PACKAGE_WAVPACK
+
+endif
diff --git a/package/gstreamer/gst-plugins-good/gst-plugins-good-linux36.patch b/package/gstreamer/gst-plugins-good/gst-plugins-good-linux36.patch
new file mode 100644
index 000000000..5d7cd932e
--- /dev/null
+++ b/package/gstreamer/gst-plugins-good/gst-plugins-good-linux36.patch
@@ -0,0 +1,37 @@
+Fix building with Linux headers 3.6
+
+Signed-off-by: Markos Chandras <markos.chandras@imgtec.com>
+
+From bfb1ac952b4c3caaba0297bbe7dc73ea92f9b292 Mon Sep 17 00:00:00 2001
+From: Matthias Clasen <mclasen@redhat.com>
+Date: Thu, 09 Aug 2012 07:35:23 +0000
+Subject: v4l2: fix build with recent kernels, the v4l2_buffer input field was removed
+
+This was unused apparently and removed in the kernel in commit:
+
+ From 2b719d7baf490e24ce7d817c6337b7c87fda84c1 Mon Sep 17 00:00:00 2001
+ From: Sakari Ailus <sakari.ailus@iki.fi>
+ Date: Wed, 2 May 2012 09:40:03 -0300
+ Subject: [PATCH] [media] v4l: drop v4l2_buffer.input and V4L2_BUF_FLAG_INPUT
+
+ Remove input field in struct v4l2_buffer and flag V4L2_BUF_FLAG_INPUT which
+ tells the former is valid. The flag is used by no driver currently.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=681491
+---
+(limited to 'sys/v4l2/gstv4l2bufferpool.c')
+
+diff --git a/sys/v4l2/gstv4l2bufferpool.c b/sys/v4l2/gstv4l2bufferpool.c
+index 2e3a563..5aaed5a 100644
+--- a/sys/v4l2/gstv4l2bufferpool.c
++++ b/sys/v4l2/gstv4l2bufferpool.c
+@@ -182,7 +182,6 @@ gst_v4l2_buffer_new (GstV4l2BufferPool * pool, guint index, GstCaps * caps)
+ GST_LOG_OBJECT (pool->v4l2elem, " MMAP offset: %u",
+ ret->vbuffer.m.offset);
+ GST_LOG_OBJECT (pool->v4l2elem, " length: %u", ret->vbuffer.length);
+- GST_LOG_OBJECT (pool->v4l2elem, " input: %u", ret->vbuffer.input);
+
+ ret->mmap_length = ret->vbuffer.length;
+ data = (guint8 *) v4l2_mmap (0, ret->vbuffer.length,
+--
+cgit v0.9.0.2-2-gbebe
diff --git a/package/gstreamer/gst-plugins-good/gst-plugins-good-v4l2-fix-compilation-against-newer-kernel-headers.patch b/package/gstreamer/gst-plugins-good/gst-plugins-good-v4l2-fix-compilation-against-newer-kernel-headers.patch
new file mode 100644
index 000000000..62c3bb24e
--- /dev/null
+++ b/package/gstreamer/gst-plugins-good/gst-plugins-good-v4l2-fix-compilation-against-newer-kernel-headers.patch
@@ -0,0 +1,30 @@
+From 8e633d2059cb835448021cf79becb487aff10975 Mon Sep 17 00:00:00 2001
+From: Bastien Nocera <hadess@hadess.net>
+Date: Mon, 18 Mar 2013 14:59:35 +0000
+Subject: [PATCH] v4l2: fix compilation against newer kernel headers as on
+ FC19
+
+---
+ sys/v4l2/v4l2_calls.c | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/sys/v4l2/v4l2_calls.c b/sys/v4l2/v4l2_calls.c
+index 07d390a..4c10f4f 100644
+--- a/sys/v4l2/v4l2_calls.c
++++ b/sys/v4l2/v4l2_calls.c
+@@ -291,8 +291,12 @@ gst_v4l2_fill_lists (GstV4l2Object * v4l2object)
+ break;
+ case V4L2_CID_HFLIP:
+ case V4L2_CID_VFLIP:
++#ifndef V4L2_CID_PAN_RESET
+ case V4L2_CID_HCENTER:
++#endif
++#ifndef V4L2_CID_TILT_RESET
+ case V4L2_CID_VCENTER:
++#endif
+ #ifdef V4L2_CID_PAN_RESET
+ case V4L2_CID_PAN_RESET:
+ #endif
+--
+1.7.10.4
+
diff --git a/package/gstreamer/gst-plugins-good/gst-plugins-good.mk b/package/gstreamer/gst-plugins-good/gst-plugins-good.mk
new file mode 100644
index 000000000..eba057196
--- /dev/null
+++ b/package/gstreamer/gst-plugins-good/gst-plugins-good.mk
@@ -0,0 +1,393 @@
+################################################################################
+#
+# gst-plugins-good
+#
+################################################################################
+
+GST_PLUGINS_GOOD_VERSION = 0.10.31
+GST_PLUGINS_GOOD_SOURCE = gst-plugins-good-$(GST_PLUGINS_GOOD_VERSION).tar.bz2
+GST_PLUGINS_GOOD_SITE = http://gstreamer.freedesktop.org/src/gst-plugins-good
+
+GST_PLUGINS_GOOD_CONF_OPT = \
+ --disable-debug \
+ --disable-examples \
+ --disable-directsound \
+ --disable-sunaudio \
+ --disable-osx_audio \
+ --disable-osx_video \
+ --disable-aalib \
+ --disable-aalibtest \
+ --disable-esd \
+ --disable-esdtest \
+ --disable-shout2
+
+GST_PLUGINS_GOOD_DEPENDENCIES = gstreamer gst-plugins-base
+
+ifeq ($(BR2_PACKAGE_XORG7),y)
+GST_PLUGINS_GOOD_DEPENDENCIES += xlib_libX11 xlib_libXext xlib_libXv
+GST_PLUGINS_GOOD_CONF_OPT += \
+ --enable-x \
+ --enable-xshm \
+ --enable-xvideo
+else
+GST_PLUGINS_GOOD_CONF_OPT += \
+ --disable-x \
+ --disable-xshm \
+ --disable-xvideo
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_JPEG),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-jpeg
+GST_PLUGINS_GOOD_DEPENDENCIES += jpeg
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-jpeg
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PNG),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-libpng
+GST_PLUGINS_GOOD_DEPENDENCIES += libpng
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-libpng
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_BZ2),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-bz2
+GST_PLUGINS_GOOD_DEPENDENCIES += bzip2
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-bz2
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_ZLIB),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-zlib
+GST_PLUGINS_GOOD_DEPENDENCIES += zlib
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-zlib
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_ALPHA),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-alpha
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-alpha
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_APETAG),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-apetag
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-apetag
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_AUDIOFX),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-audiofx
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-audiofx
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_AUDIOPARSERS),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-audioparsers
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-audioparsers
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_AUPARSE),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-auparse
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-auparse
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_AUTODETECT),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-autodetect
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-autodetect
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_AVI),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-avi
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-avi
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_CUTTER),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-cutter
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-cutter
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_DEBUGUTILS),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-debugutils
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-debugutils
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_DEINTERLACE),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-deinterlace
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-deinterlace
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_EFFECTV),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-effectv
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-effectv
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_EQUALIZER),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-equalizer
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-equalizer
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_FLV),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-flv
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-flv
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_FLX),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-flx
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-flx
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_GOOM),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-goom
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-goom
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_GOOM2K1),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-goom2k1
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-goom2k1
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_ID3DEMUX),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-id3demux
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-id3demux
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_ICYDEMUX),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-icydemux
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-icydemux
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_IMAGEFREEZE),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-imagefreeze
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-imagefreeze
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_INTERLEAVE),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-interleave
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-interleave
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_ISOMP4),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-isomp4
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-isomp4
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_LAW),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-law
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-law
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_LEVEL),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-level
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-level
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_MATROSKA),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-matroska
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-matroska
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_MONOSCOPE),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-monoscope
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-monoscope
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_MULTIFILE),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-multifile
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-multifile
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_MULTIPART),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-multipart
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-multipart
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_REPLAYGAIN),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-replaygain
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-replaygain
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_RTP),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-rtp
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-rtp
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_RTPMANAGER),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-rtpmanager
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-rtpmanager
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_RTSP),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-rtsp
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-rtsp
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_SHAPEWIPE),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-shapewipe
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-shapewipe
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_SMPTE),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-smpte
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-smpte
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_SPECTRUM),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-spectrum
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-spectrum
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_UDP),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-udp
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-udp
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_VIDEOBOX),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-videobox
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-videobox
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_VIDEOCROP),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-videocrop
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-videocrop
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_VIDEOFILTER),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-videofilter
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-videofilter
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_VIDEOMIXER),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-videomixer
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-videomixer
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_WAVENC),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-wavenc
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-wavenc
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_WAVPARSE),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-wavparse
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-wavparse
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_Y4M),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-y4m
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-y4m
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_V4L2),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-gst_v4l2
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-gst_v4l2
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_ANNODEX),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-annodex
+GST_PLUGINS_GOOD_DEPENDENCIES += libxml2
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-annodex
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_CAIRO),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-cairo
+GST_PLUGINS_GOOD_DEPENDENCIES += cairo
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-cairo
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_FLAC),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-flac
+GST_PLUGINS_GOOD_DEPENDENCIES += flac
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-flac
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_GDKPIXBUF),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-gdk_pixbuf
+GST_PLUGINS_GOOD_DEPENDENCIES += gdk-pixbuf
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-gdk_pixbuf
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_OSS),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-oss
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-oss
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_OSS4),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-oss4
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-oss4
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_PULSE),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-pulse
+GST_PLUGINS_GOOD_DEPENDENCIES += pulseaudio
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-pulse
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_SOUPHTTPSRC),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-soup
+GST_PLUGINS_GOOD_DEPENDENCIES += libsoup
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-soup
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_SPEEX),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-speex
+GST_PLUGINS_GOOD_DEPENDENCIES += speex
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-speex
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_WAVPACK),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-wavpack
+GST_PLUGINS_GOOD_DEPENDENCIES += wavpack
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-wavpack
+endif
+
+$(eval $(autotools-package))