summaryrefslogtreecommitdiff
path: root/package/gstreamer1
diff options
context:
space:
mode:
authorBernd Kuhls <bernd.kuhls@t-online.de>2016-06-19 18:20:29 +0200
committerPeter Korsgaard <peter@korsgaard.com>2016-06-19 23:09:04 +0200
commit58ef923059f6f861022bb2b4f25b951800dc7f03 (patch)
tree6a1e314053c5994bc891ea578294644add4e0db1 /package/gstreamer1
parentbf5c4641823e3e4c4669348a547b540a276ece67 (diff)
package/gstreamer1/gst1-plugins-ugly: libdvdread can now be linked statically
After libdvdread bump to version 5.0.3 static linking works, tested using this defconfig: http://autobuild.buildroot.net/toolchains/configs/br-arm-full-static.config Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/gstreamer1')
-rw-r--r--package/gstreamer1/gst1-plugins-ugly/Config.in4
-rw-r--r--package/gstreamer1/gst1-plugins-ugly/gst1-plugins-ugly.mk4
2 files changed, 4 insertions, 4 deletions
diff --git a/package/gstreamer1/gst1-plugins-ugly/Config.in b/package/gstreamer1/gst1-plugins-ugly/Config.in
index 995835e41..f30163aa0 100644
--- a/package/gstreamer1/gst1-plugins-ugly/Config.in
+++ b/package/gstreamer1/gst1-plugins-ugly/Config.in
@@ -40,14 +40,10 @@ comment "plugins with external dependencies (there may be more available)"
config BR2_PACKAGE_GST1_PLUGINS_UGLY_PLUGIN_DVDREAD
bool "dvdread"
- depends on !BR2_STATIC_LIBS # libdvdread
select BR2_PACKAGE_LIBDVDREAD
help
Access a DVD with dvdread
-comment "dvdread needs a toolchain w/ dynamic library"
- depends on BR2_STATIC_LIBS
-
config BR2_PACKAGE_GST1_PLUGINS_UGLY_PLUGIN_LAME
bool "lame (*.mp3 audio encoder)"
select BR2_PACKAGE_LAME
diff --git a/package/gstreamer1/gst1-plugins-ugly/gst1-plugins-ugly.mk b/package/gstreamer1/gst1-plugins-ugly/gst1-plugins-ugly.mk
index d37908c34..8864b04c7 100644
--- a/package/gstreamer1/gst1-plugins-ugly/gst1-plugins-ugly.mk
+++ b/package/gstreamer1/gst1-plugins-ugly/gst1-plugins-ugly.mk
@@ -59,6 +59,10 @@ GST1_PLUGINS_UGLY_CONF_OPTS += --disable-realmedia
endif
ifeq ($(BR2_PACKAGE_GST1_PLUGINS_UGLY_PLUGIN_DVDREAD),y)
+# configure does not use pkg-config to detect libdvdread
+ifeq ($(BR2_PACKAGE_LIBDVDCSS)$(BR2_STATIC_LIBS),yy)
+GST1_PLUGINS_UGLY_CONF_ENV += LIBS="-ldvdcss"
+endif
GST1_PLUGINS_UGLY_CONF_OPTS += --enable-dvdread
GST1_PLUGINS_UGLY_DEPENDENCIES += libdvdread
GST1_PLUGINS_UGLY_HAS_GPL_LICENSE = y