summaryrefslogtreecommitdiff
path: root/package/gstreamer1
diff options
context:
space:
mode:
authorBernd Kuhls <bernd.kuhls@t-online.de>2014-10-19 11:59:01 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-10-19 17:07:14 +0200
commit822a757456e8d5f2b68ed8fd9b242efc6327958e (patch)
treee27b8211efe88c3107868d09c5f1515aff1b051f /package/gstreamer1
parent2641edb8c49e0531af87eb00a35784785d604ec9 (diff)
infra: Move --enable/--disable-debug to package/Makefile.in
A lot of packages ignored BR2_ENABLE_DEBUG. This patch simplifies the handling of this option by adding the corresponding configure option to the global Makefile for target packages. For host packages --disable-debug is added to the global Makefile. Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/gstreamer1')
-rw-r--r--package/gstreamer1/gst1-libav/gst1-libav.mk5
-rw-r--r--package/gstreamer1/gst1-plugins-bad/gst1-plugins-bad.mk1
-rw-r--r--package/gstreamer1/gst1-plugins-base/gst1-plugins-base.mk3
-rw-r--r--package/gstreamer1/gst1-plugins-good/gst1-plugins-good.mk1
-rw-r--r--package/gstreamer1/gst1-plugins-ugly/gst1-plugins-ugly.mk5
-rw-r--r--package/gstreamer1/gstreamer1/gstreamer1.mk1
6 files changed, 3 insertions, 13 deletions
diff --git a/package/gstreamer1/gst1-libav/gst1-libav.mk b/package/gstreamer1/gst1-libav/gst1-libav.mk
index b903da2d0..6fdf09145 100644
--- a/package/gstreamer1/gst1-libav/gst1-libav.mk
+++ b/package/gstreamer1/gst1-libav/gst1-libav.mk
@@ -10,10 +10,7 @@ GST1_LIBAV_SITE = http://gstreamer.freedesktop.org/src/gst-libav
GST1_LIBAV_DEPENDENCIES = host-pkgconf gstreamer1 gst1-plugins-base
-GST1_LIBAV_CONF_EXTRA_OPTS = \
- --cross-prefix=$(TARGET_CROSS) \
- --target-os=linux \
- $(if $(BR2_ENABLE_DEBUG),--enable-debug,--disable-debug)
+GST1_LIBAV_CONF_EXTRA_OPTS = --cross-prefix=$(TARGET_CROSS) --target-os=linux
ifeq ($(BR2_PACKAGE_ZLIB),y)
GST1_LIBAV_CONF_EXTRA_OPTS += --enable-zlib
diff --git a/package/gstreamer1/gst1-plugins-bad/gst1-plugins-bad.mk b/package/gstreamer1/gst1-plugins-bad/gst1-plugins-bad.mk
index cf4648d80..a8dbd53ac 100644
--- a/package/gstreamer1/gst1-plugins-bad/gst1-plugins-bad.mk
+++ b/package/gstreamer1/gst1-plugins-bad/gst1-plugins-bad.mk
@@ -18,7 +18,6 @@ GST1_PLUGINS_BAD_GETTEXTIZE = YES
GST1_PLUGINS_BAD_CONF_OPTS = \
--disable-examples \
- --disable-debug \
--disable-valgrind \
--disable-directsound \
--disable-wsapi \
diff --git a/package/gstreamer1/gst1-plugins-base/gst1-plugins-base.mk b/package/gstreamer1/gst1-plugins-base/gst1-plugins-base.mk
index bc19bac38..15368a2dc 100644
--- a/package/gstreamer1/gst1-plugins-base/gst1-plugins-base.mk
+++ b/package/gstreamer1/gst1-plugins-base/gst1-plugins-base.mk
@@ -23,8 +23,7 @@ GST1_PLUGINS_BASE_CONF_OPTS = \
--disable-oggtest \
--disable-vorbistest \
--disable-freetypetest \
- --disable-valgrind \
- --disable-debug
+ --disable-valgrind
# Options which require currently unpackaged libraries
GST1_PLUGINS_BASE_CONF_OPTS += \
diff --git a/package/gstreamer1/gst1-plugins-good/gst1-plugins-good.mk b/package/gstreamer1/gst1-plugins-good/gst1-plugins-good.mk
index 0167e4fe9..7c40b9952 100644
--- a/package/gstreamer1/gst1-plugins-good/gst1-plugins-good.mk
+++ b/package/gstreamer1/gst1-plugins-good/gst1-plugins-good.mk
@@ -11,7 +11,6 @@ GST1_PLUGINS_GOOD_LICENSE_FILES = COPYING
GST1_PLUGINS_GOOD_LICENSE = LGPLv2.1+
GST1_PLUGINS_GOOD_CONF_OPTS = \
- --disable-debug \
--disable-valgrind \
--disable-examples \
--disable-directsound \
diff --git a/package/gstreamer1/gst1-plugins-ugly/gst1-plugins-ugly.mk b/package/gstreamer1/gst1-plugins-ugly/gst1-plugins-ugly.mk
index 656189d7e..34558322e 100644
--- a/package/gstreamer1/gst1-plugins-ugly/gst1-plugins-ugly.mk
+++ b/package/gstreamer1/gst1-plugins-ugly/gst1-plugins-ugly.mk
@@ -11,10 +11,7 @@ GST1_PLUGINS_UGLY_LICENSE_FILES = COPYING
# GPL licensed plugins will append to GST1_PLUGINS_UGLY_LICENSE if enabled.
GST1_PLUGINS_UGLY_LICENSE = LGPLv2.1+
-GST1_PLUGINS_UGLY_CONF_OPTS = \
- --disable-examples \
- --disable-debug \
- --disable-valgrind
+GST1_PLUGINS_UGLY_CONF_OPTS = --disable-examples --disable-valgrind
GST_PLUGINS_BAD1_CONF_OPTS += \
--disable-a52dec \
diff --git a/package/gstreamer1/gstreamer1/gstreamer1.mk b/package/gstreamer1/gstreamer1/gstreamer1.mk
index 9d49e6da2..be84d5be9 100644
--- a/package/gstreamer1/gstreamer1/gstreamer1.mk
+++ b/package/gstreamer1/gstreamer1/gstreamer1.mk
@@ -25,7 +25,6 @@ GSTREAMER1_CONF_OPTS = \
--disable-examples \
--disable-tests \
--disable-failing-tests \
- --disable-debug \
--disable-valgrind \
--disable-benchmarks \
--disable-check \