summaryrefslogtreecommitdiff
path: root/package/gstreamer1
diff options
context:
space:
mode:
authorPeter Korsgaard <peter@korsgaard.com>2015-06-22 21:42:54 +0200
committerPeter Korsgaard <peter@korsgaard.com>2015-06-22 22:13:33 +0200
commitbff865186434554e357ecdf6b2b3da4fd9cc2053 (patch)
tree283779c14bddabf6887fafd3e4d3208706f3415c /package/gstreamer1
parent962ffda68cd9b0c4ab6055c97c14e762a5439571 (diff)
gst1-plugins-bad: fix egl detection
Some egl implementations needs special compiler flags or defines (E.G. mesa3d for wayland needs to pass -DMESA_EGL_NO_X11_HEADERS to not try to include X11 headers). This is correctly included in the .pc file, but the configure logic doesn't use pkg-config so help it along. Likewise, some implementations may need to link against other libraries, so also pass LIBS. Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/gstreamer1')
-rw-r--r--package/gstreamer1/gst1-plugins-bad/gst1-plugins-bad.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/package/gstreamer1/gst1-plugins-bad/gst1-plugins-bad.mk b/package/gstreamer1/gst1-plugins-bad/gst1-plugins-bad.mk
index db323b97c..faf0e2ae0 100644
--- a/package/gstreamer1/gst1-plugins-bad/gst1-plugins-bad.mk
+++ b/package/gstreamer1/gst1-plugins-bad/gst1-plugins-bad.mk
@@ -118,6 +118,9 @@ endif
ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_LIB_OPENGL_EGL),y)
GST1_PLUGINS_BAD_CONF_OPTS += --enable-egl
GST1_PLUGINS_BAD_DEPENDENCIES += libegl
+GST1_PLUGINS_BAD_CONF_ENV += \
+ CPPFLAGS="$(TARGET_CPPFLAGS) $(shell $(PKG_CONFIG_HOST_BINARY) --cflags egl)" \
+ LIBS="$(shell $(PKG_CONFIG_HOST_BINARY) --libs egl)"
else
GST1_PLUGINS_BAD_CONF_OPTS += --disable-egl
endif