summaryrefslogtreecommitdiff
path: root/package/gstreamer
diff options
context:
space:
mode:
authorDanomi Manchego <danomimanchego123@gmail.com>2016-12-28 21:52:08 -0500
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2017-01-27 21:49:56 +1300
commit13b8ed48c33d5d9deebb64ae189501b375198890 (patch)
tree6cb906e7a758a9ec1303cf0652e4f03fa1ca4c06 /package/gstreamer
parentb6e3dc51bcc397bc79df2a3138fad03123b1f90e (diff)
gst-plugins-base: add missing dependency on libxml2 for subparse
The gst-plugins-base configure script claims that the subparse plugin is dependency-less - but it also silently disables subparse if libxml2 is not available. So depend on libxml2 when subparse is selected. Note: the analogous gst1 subparse plugin does not have this requirement. Signed-off-by: Danomi Manchego <danomimanchego123@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/gstreamer')
-rw-r--r--package/gstreamer/gst-plugins-base/Config.in7
-rw-r--r--package/gstreamer/gst-plugins-base/gst-plugins-base.mk1
2 files changed, 5 insertions, 3 deletions
diff --git a/package/gstreamer/gst-plugins-base/Config.in b/package/gstreamer/gst-plugins-base/Config.in
index 8ad9a8ef8..e9c8239f7 100644
--- a/package/gstreamer/gst-plugins-base/Config.in
+++ b/package/gstreamer/gst-plugins-base/Config.in
@@ -46,9 +46,6 @@ config BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_PLAYBACK
bool "playback (mandatory)"
default y
-config BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_SUBPARSE
- bool "subparse"
-
config BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_TCP
bool "tcp"
@@ -92,6 +89,10 @@ comment "pango plugin needs a toolchain w/ C++"
depends on !BR2_INSTALL_LIBSTDCPP
depends on BR2_TOOLCHAIN_HAS_SYNC_4
+config BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_SUBPARSE
+ bool "subparse"
+ select BR2_PACKAGE_LIBXML2
+
config BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_THEORA
bool "theora (*.ogg video)"
select BR2_PACKAGE_LIBTHEORA
diff --git a/package/gstreamer/gst-plugins-base/gst-plugins-base.mk b/package/gstreamer/gst-plugins-base/gst-plugins-base.mk
index e1374ed80..51c22a90b 100644
--- a/package/gstreamer/gst-plugins-base/gst-plugins-base.mk
+++ b/package/gstreamer/gst-plugins-base/gst-plugins-base.mk
@@ -111,6 +111,7 @@ endif
ifeq ($(BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_SUBPARSE),y)
GST_PLUGINS_BASE_CONF_OPTS += --enable-subparse
+GST_PLUGINS_BASE_DEPENDENCIES += libxml2
else
GST_PLUGINS_BASE_CONF_OPTS += --disable-subparse
endif