summaryrefslogtreecommitdiff
path: root/package/gstreamer
diff options
context:
space:
mode:
authorVolkov Viacheslav <sv99@inbox.ru>2015-10-29 09:45:48 +0300
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-12-20 12:46:12 +0100
commit1b5352e7942990ff65037889e2e35d67d7b2671a (patch)
treea8754f1d934bf6903c117703b7d0a47d1b968f07 /package/gstreamer
parent3da4704bb2ac52146cda438ad68e9ed097397d76 (diff)
gst-plugins-bad: add zbar plugin
Add gstreamer zbar plugin. Signed-off-by: Viacheslav Volkov <sv99@inbox.ru> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/gstreamer')
-rw-r--r--package/gstreamer/gst-plugins-bad/Config.in4
-rw-r--r--package/gstreamer/gst-plugins-bad/gst-plugins-bad.mk7
2 files changed, 11 insertions, 0 deletions
diff --git a/package/gstreamer/gst-plugins-bad/Config.in b/package/gstreamer/gst-plugins-bad/Config.in
index 6aa93de54..3bfd12b52 100644
--- a/package/gstreamer/gst-plugins-bad/Config.in
+++ b/package/gstreamer/gst-plugins-bad/Config.in
@@ -319,4 +319,8 @@ config BR2_PACKAGE_GST_PLUGINS_BAD_PLUGIN_VP8
bool "vp8"
select BR2_PACKAGE_LIBVPX
+config BR2_PACKAGE_GST_PLUGINS_BAD_ZBAR
+ bool "zbar"
+ select BR2_PACKAGE_ZBAR
+
endif
diff --git a/package/gstreamer/gst-plugins-bad/gst-plugins-bad.mk b/package/gstreamer/gst-plugins-bad/gst-plugins-bad.mk
index fa2f124f9..98e5c1cfb 100644
--- a/package/gstreamer/gst-plugins-bad/gst-plugins-bad.mk
+++ b/package/gstreamer/gst-plugins-bad/gst-plugins-bad.mk
@@ -588,4 +588,11 @@ else
GST_PLUGINS_BAD_CONF_OPTS += --disable-vp8
endif
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BAD_ZBAR),y)
+GST_PLUGINS_BAD_CONF_OPTS += --enable-zbar
+GST_PLUGINS_BAD_DEPENDENCIES += zbar
+else
+GST_PLUGINS_BAD_CONF_OPTS += --disable-zbar
+endif
+
$(eval $(autotools-package))